Toad World® Forums

DDL Script encoding TDM 3.1.5.6

Hi,

The previous commercial version produced DDL files in “Unicode” accordong to notepad.
This gave me a problem as SQLPlus did not understand this.

The solution was to convert to “Windows ANSI” format.

TDM 3.1.5.6 uses “UTF-8”.
Unfortunately in some of my packages concerned with data import/export we use extended ascii characters (eg 0xa4) which do not seem to be supported.

Can I alter the DDL script format to be either “Windows ANSI” (preferred) or “Unicode”?

Thanks
Malcolm

Hello Malcolm,

Please select Settings | Options | Physical Model and see section SQL Script. From the ‘Encoding Used for SQL Scripts’ box, select the encoding you prefer.

Regards,

Vladka

Thanks Vladka - I didn’t spot that hiding there.

Malcolm

Hi Vladka,

I’m using TDM 5.4

In the comment field of a attribute of an entity i typed “Tên bảng tham chiếu”.

It was show exactly when i move the mouse on the attribute.

and i also set the setting: Settings | Options | Physical Model | SQL Generation Script | Encoding Used for SQL Script = UTF-8

But i get the generated SQL script like this:

COMMENT ‘Tên b?ng tham chi?u’,

With the Encoding Used for SQL Script = Unicode, the same result

How to get

COMMENT ‘Tên bảng tham chiếu’,

Thanks you.

Hi there,

What database platform and version are you using? It seems DDL (UTF-8) scripts using generated for MySQL models cannot handle the comment properly. Are you using MySQL model? I have not managed to reproduce the problem for other databases. Please let us know and we’ll fix it as soon as possible.

Regards,

Lukas

Hi Lukas,

I’m using MySql 5.6.

I use notepad to re-edit DDL script to

COMMENT ‘Tên bảng tham chiếu’,

and run script in the MySql workbench, comment in the table is OK.

Thanks for reply.

Hi again,

Thank you for the confirmation. We successfully reproduced the issue, it will be fixed in the upcoming version of TDM.

Regards,

Lukas

Hope to see next version of TDM soon.

Thanks you.

Hi Lukas,

Do you remember this thread ?

Regards,

N.Q.Hung

Hi Lukas,

This bug is fixed in the TDM 6.0 64-bit Beta

Thanks you very much.

Regards,

N.Q.Hung