Toad World® Forums

Drag file into editor doesn't work

In earlier versions of Toad for Oracle I could drag a file from explorer into the editor. Now I can’t, I get a “not allowed” mouse icon. This is a very nice function, and I would really get it back :slight_smile:

Windows 8, 64 bit

Toad for Oracle 12.11.0.66, 32 bit

Trying with 12.11.0.68, same problem. Is this identified as a problem, or is it a setup issue?

Hi Paul,

I can’t reproduce this issue you’re having. I’ve tried on Win7 and 8. I open a WE instance right on top of Toad and can drag a .sql or .txt right from WE into the Editor, loads up, no problems. I wish I could be more help but I’ve got no idea why this may not be working for you. I don’t believe there is an option in Toad that would control this.

ok, thanks for reply anyway!

Just upgraded to Toad for Oracle 12.11.0.77 (still Professional (32-bit)), same problem. Windows 8.1 Pro. I don’t have this problem on other pre-beta versions of Toad. I can’t figure out why. And I can drag’n’drop files from WE to all other programs, but not to Toad for Oracle. Frustrating…

I wasn’t able to replicate the issue either in my Win8 environment, but I did come across a couple posts that worked for some people with a similar issue.

https://www.eightforums.com/general-support/23889-cant-drag-files-explorer-into-64-bit-programs.html

I also found a another post where pressing Escape returned the functionality, but since you can do it with other applications, this one is probably not as likely to be your problem.

“I had the same problem, tried closing anything related to mouse input down (Logitech software, mouse without boarders). Eventually found the solution in a forum post about windows 7. It has something to do with another application locking the function out. Anyway, hitting escape seems to return the functionality back for me. Try it and let us know if it solves your issue.”

Thanks for reply!

I had a reboot of the laptop now, and it’s working. I have no idea what the problem could have been. As I said, drag’n’drop worked perfectly well for all other applications, but not for Toad for Oracle.