Toad World® Forums

Enable using DBA Dictionary views is not working


#1

Hi everybody,
i am using Sql Navigator version 5.5.
I have 2 users A and B.
I want to allow B to view the package body of the package that user A owns.
I have granted user B the right SELECT ON DBA_SOURCES and he can select from this view successfully.
User B does not have any of these roles : DBA,SELECT_CATALOG_ROLE or Select any table.
He has only select on DBA_SOURCES.
I select the option Enable using DBA Dictionary views, but user B still isn’t able to see the package body of a package that user A has created.

Can it be possible to enable this in this version of Sql Navigator.

Thanks,
Bye


#2

Hi,

I think granting ‘Select on DBA_source’ only let you view the source code by querying from this view. It won’t let you open the object in this schema. This is consistent with Toad as well. DBA dictionary vies only makes a difference if the user has DBA,SELECT_CATALOG_ROLE or Select any table.

Maybe you can try differet approaches.
http://www.orafaq.com/forum/t/53116/0/
http://forums.oracle.com/forums/thread.jspa?threadID=324756

Gwen


#3

Hi, Gwen

I read somewhere , that with Toad,
you could create a synonym DBA_SOURCE in your schema, that points to a view in the SYS schema that can be like the following:

Select * from dba_source where owner=‘USER’

After granting the user SELECT on this view, you could enable DBA Views in Toad, and then the user could see the package body.
I would like to try the same thing in Sql Navigator.


#4

The following is the link i have read

http://asktom.oracle.com/pls/asktom/f?p=100:11:0::::P11_QUESTION_ID:52284726269554


#5

The thing is I checked it with Toad and it doesn’t seem to work either. But again, I’m not a Toad expert. Have you managed to make it work in Toad?
Gwen


#6

I haven’t yet tried that in Toad.
I am using Sql Navigator.

thanks


#7

HI,
i tried Toad for Oracle Xpert and the package body is showing, only with the DEBUG privilege on the package, and with no other granted privilege.
I would like to have the same result in SQL Navigator.It should be working.


#8

Hi,

I tried granting debug privilege on the package but both Toad & Nav didn’t show package or package body. The only difference I see is when Execute privilege is granted. Would you mind providing us with the extracted DDL of this user (make sure preference to ‘Include Object Grants’ is ON)?

Gwen


#9

The issue in this thread has been followed up in this one:

http://sqlnavigator.inside.quest.com/thread.jspa?messageID=30381&#30381