Toad World® Forums

formatter question


#21

That would probably be because I did a trial of the SQL optimizer, but I
do have a commercial license through Ithaca College.

Erwin Rollauer wrote:

You have to have the latest GA version. Trial versions don’t count for
beta program

From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] *On Behalf
Of *Wendy Penfold
Sent: December 21, 2009 12:10 PM
To: toad@yahoogroups.com
Subject: Re: [toad] Re: RE: formatter question

I installed the Beta, but can’t get it to run because it says I don’t
have the most recent version of Toad installed, but when I ‘check for
updates’, it says I do have the most recent version. My license says
I have a ‘Trial’ version…could that be the issue with runnning the beta?

So, I tried copying the QP5.dll to my commercial install directory and
doing a source compare, but the 2 versions of the package are still
not being formatted the same. Could it be because one version of the
database is UTF-8 and the other is not?

Bert Scalzo wrote:

Message from: bscalzo

The beta has two downloads (as Jeff points out and that many people
don’t understand). The installer is done once at the beginning of the
beta cycle - and will lay down the very first beta and all the files.
The second download is updated regularly - like once or twice a week -
and is just a zip file you unzip into the beta install directory and
contains just the files that changed …


Historical Messages

Author: Bert Scalzo
Date: Mon Dec 21 07:00:04 PST 2009
The beta has two downloads (as Jeff points out and that many people
don’t understand). The installer is done once at the beginning of the
beta cycle - and will lay down the very first beta and all the files.
The second download is updated regularly - like once or twice a week -
and is just a zip file you unzip into the beta install directory and
contains just the files that changed …
__

Author: Jeff Smith
Date: Mon Dec 21 06:31:28 PST 2009
My copy has the .142 version. You downloaded the beta, and then also
ran the updater in the 2nd link on the beta page?
__

Author: wpenfold
Date: Mon Dec 21 06:16:30 PST 2009
Hi Jeff, I tried downloading the lastest beta and installing it, but
the QP5 version is 5.136.908.31019, Andre says it should be 5.142?
Wendy Jeff Smith wrote: Available in the beta only
__

Author: Jeff Smith
Date: Mon Dec 21 05:28:47 PST 2009
Available in the beta only
__

Author: Rob Zijlstra
Date: Mon Dec 21 00:22:09 PST 2009

__

Author: wpenfold
Date: Fri Dec 18 10:41:42 PST 2009
Thanks! Brad Boddicker wrote: Correct, but be aware that commercial
Toad 10 has not been certified with any other QP5.dll version other
than the one it ships with. It will most likely work fine, but if you
have any problems, be sure you hold on to the original version.
__

Author: Brad Boddicker
Date: Fri Dec 18 08:07:26 PST 2009
Correct, but be aware that commercial Toad 10 has not been certified
with any other QP5.dll version other than the one it ships with. It
will most likely work fine, but if you have any problems, be sure you
hold on to the original version.
__

Author: George.Meltser@aigfpc.com
Date: Fri Dec 18 08:01:40 PST 2009
Thank you, John. I think “Row Select Off” should a default behavior.
__

Author: John Dorlon
Date: Fri Dec 18 07:17:42 PST 2009
Rt-click, turn off row select.
__

Author: George.Meltser@aigfpc.com
Date: Fri Dec 18 07:11:57 PST 2009
There is one annoyance in TOAD 10 concerning the subject. While in
version 9 i was able to hit F4 on the table and then CTRL-C the column
i needed to use, it now copies the entire row in the clipboard. The
same problem exists if i need just an index or a trigger name. For
example, this is what gets copied to the clipboard for the index:
PLAIN CDREFENTITY_UQ Y YES 1 CD_ENTITY_NAME Asc 1 CLIENT_ADMIN while i
want only CDREFENTITY_UQ Is there an option that controls what is
being copied? Many thanks.
__

Author: wpenfold
Date: Fri Dec 18 06:25:48 PST 2009
Hi Brad, I’m guessing that means I can’t just download the new QP5
version…? I’ll have to install the toad beta and then possibly move
the new QP5 version to my commercial install? Wendy Brad Boddicker
wrote: Hi Wendy, The version Andre is speaking of is in the Toad
beta. If you?re interested in trying it out, go here:
http://www.toadforo racle.com/ beta.jspa
__

Author: Brad Boddicker
Date: Thu Dec 17 13:13:43 PST 2009
Hi Wendy, The version Andre is speaking of is in the Toad beta. If
you?re interested in trying it out, go here:
http://www.toadfororacle.com/beta.jspa
__

Author: wpenfold
Date: Thu Dec 17 12:39:15 PST 2009
Hi Andre, Thanks! I can find just that file on the website and
download it? When I do Help | Check for updates it says I have the
most recent version of Toad. Wendy Andre Vergison wrote: Wendy,
After you sent me the files I saw that the ?bad? file contains
variable declarations with %TYPE. You?re using QP5 version 5.139.
Unfortunately this version has issues with %TYPE and %ROWTYPE which
sometimes will cause parts of the text not to get formatted. Please
try to use 5.142, found the latest Toad drops if I?m not mistaken.
This formats your file most fine. Sorry about that. Thanks, Andre
__

Author: Andre Vergison
Date: Wed Dec 16 13:41:55 PST 2009
Wendy, After you sent me the files I saw that the ?bad? file contains
variable declarations with %TYPE. You?re using QP5 version 5.139.
Unfortunately this version has issues with %TYPE and %ROWTYPE which
sometimes will cause parts of the text not to get formatted. Please
try to use 5.142, found the latest Toad drops if I?m not mistaken.
This formats your file most fine. Sorry about that. Thanks, Andre
__

Author: wpenfold
Date: Tue Dec 15 12:11:15 PST 2009
I have the same package source from 2 software versions saved in a
folder on my computer and open in the editor so I can compare them. I
have my toad options set to ‘format when opening a file’, but when I
compare the files they show many differences because the are not
formatted the same. I clicked the ‘format code’ icon on both to format
them. They both appear to format ok, but one formats and one does not.
I tried changing the code and formatting again…same result. No
errors, one of them just doesn’t format even though it says it does.
There is really not much difference between the files. What would
cause one of them not to format and how can I work around this?
__


That would probably be because I did a trial of the SQL optimizer, but I do have
a commercial license through Ithaca College.

Erwin Rollauer wrote:

You have to have the latest GA version. Trial versions don’t count for
beta program
att1.dat (26.6 KB)


#22

That would probably be because I did a trial of the SQL optimizer, but I
do have a commercial license through Ithaca College.

Erwin Rollauer wrote:

You have to have the latest GA version. Trial versions don’t count for
beta program

From: toad@yahoogroups.com [mailto:toad@yahoogroups.com] *On Behalf
Of *Wendy Penfold
Sent: December 21, 2009 12:10 PM
To: toad@yahoogroups.com
Subject: Re: [toad] Re: RE: formatter question

I installed the Beta, but can’t get it to run because it says I don’t
have the most recent version of Toad installed, but when I ‘check for
updates’, it says I do have the most recent version. My license says
I have a ‘Trial’ version…could that be the issue with runnning the beta?

So, I tried copying the QP5.dll to my commercial install directory and
doing a source compare, but the 2 versions of the package are still
not being formatted the same. Could it be because one version of the
database is UTF-8 and the other is not?

Bert Scalzo wrote:

Message from: bscalzo

The beta has two downloads (as Jeff points out and that many people
don’t understand). The installer is done once at the beginning of the
beta cycle - and will lay down the very first beta and all the files.
The second download is updated regularly - like once or twice a week -
and is just a zip file you unzip into the beta install directory and
contains just the files that changed …


Historical Messages

Author: Bert Scalzo
Date: Mon Dec 21 07:00:04 PST 2009
The beta has two downloads (as Jeff points out and that many people
don’t understand). The installer is done once at the beginning of the
beta cycle - and will lay down the very first beta and all the files.
The second download is updated regularly - like once or twice a week -
and is just a zip file you unzip into the beta install directory and
contains just the files that changed …
__

Author: Jeff Smith
Date: Mon Dec 21 06:31:28 PST 2009
My copy has the .142 version. You downloaded the beta, and then also
ran the updater in the 2nd link on the beta page?
__

Author: wpenfold
Date: Mon Dec 21 06:16:30 PST 2009
Hi Jeff, I tried downloading the lastest beta and installing it, but
the QP5 version is 5.136.908.31019, Andre says it should be 5.142?
Wendy Jeff Smith wrote: Available in the beta only
__

Author: Jeff Smith
Date: Mon Dec 21 05:28:47 PST 2009
Available in the beta only
__

Author: Rob Zijlstra
Date: Mon Dec 21 00:22:09 PST 2009

__

Author: wpenfold
Date: Fri Dec 18 10:41:42 PST 2009
Thanks! Brad Boddicker wrote: Correct, but be aware that commercial
Toad 10 has not been certified with any other QP5.dll version other
than the one it ships with. It will most likely work fine, but if you
have any problems, be sure you hold on to the original version.
__

Author: Brad Boddicker
Date: Fri Dec 18 08:07:26 PST 2009
Correct, but be aware that commercial Toad 10 has not been certified
with any other QP5.dll version other than the one it ships with. It
will most likely work fine, but if you have any problems, be sure you
hold on to the original version.
__

Author: George.Meltser@aigfpc.com
Date: Fri Dec 18 08:01:40 PST 2009
Thank you, John. I think “Row Select Off” should a default behavior.
__

Author: John Dorlon
Date: Fri Dec 18 07:17:42 PST 2009
Rt-click, turn off row select.
__

Author: George.Meltser@aigfpc.com
Date: Fri Dec 18 07:11:57 PST 2009
There is one annoyance in TOAD 10 concerning the subject. While in
version 9 i was able to hit F4 on the table and then CTRL-C the column
i needed to use, it now copies the entire row in the clipboard. The
same problem exists if i need just an index or a trigger name. For
example, this is what gets copied to the clipboard for the index:
PLAIN CDREFENTITY_UQ Y YES 1 CD_ENTITY_NAME Asc 1 CLIENT_ADMIN while i
want only CDREFENTITY_UQ Is there an option that controls what is
being copied? Many thanks.
__

Author: wpenfold
Date: Fri Dec 18 06:25:48 PST 2009
Hi Brad, I’m guessing that means I can’t just download the new QP5
version…? I’ll have to install the toad beta and then possibly move
the new QP5 version to my commercial install? Wendy Brad Boddicker
wrote: Hi Wendy, The version Andre is speaking of is in the Toad
beta. If you?re interested in trying it out, go here:
http://www.toadforo racle.com/ beta.jspa
__

Author: Brad Boddicker
Date: Thu Dec 17 13:13:43 PST 2009
Hi Wendy, The version Andre is speaking of is in the Toad beta. If
you?re interested in trying it out, go here:
http://www.toadfororacle.com/beta.jspa
__

Author: wpenfold
Date: Thu Dec 17 12:39:15 PST 2009
Hi Andre, Thanks! I can find just that file on the website and
download it? When I do Help | Check for updates it says I have the
most recent version of Toad. Wendy Andre Vergison wrote: Wendy,
After you sent me the files I saw that the ?bad? file contains
variable declarations with %TYPE. You?re using QP5 version 5.139.
Unfortunately this version has issues with %TYPE and %ROWTYPE which
sometimes will cause parts of the text not to get formatted. Please
try to use 5.142, found the latest Toad drops if I?m not mistaken.
This formats your file most fine. Sorry about that. Thanks, Andre
__

Author: Andre Vergison
Date: Wed Dec 16 13:41:55 PST 2009
Wendy, After you sent me the files I saw that the ?bad? file contains
variable declarations with %TYPE. You?re using QP5 version 5.139.
Unfortunately this version has issues with %TYPE and %ROWTYPE which
sometimes will cause parts of the text not to get formatted. Please
try to use 5.142, found the latest Toad drops if I?m not mistaken.
This formats your file most fine. Sorry about that. Thanks, Andre
__

Author: wpenfold
Date: Tue Dec 15 12:11:15 PST 2009
I have the same package source from 2 software versions saved in a
folder on my computer and open in the editor so I can compare them. I
have my toad options set to ‘format when opening a file’, but when I
compare the files they show many differences because the are not
formatted the same. I clicked the ‘format code’ icon on both to format
them. They both appear to format ok, but one formats and one does not.
I tried changing the code and formatting again…same result. No
errors, one of them just doesn’t format even though it says it does.
There is really not much difference between the files. What would
cause one of them not to format and how can I work around this?
__


That would probably be because I did a trial of the SQL optimizer, but I do have
a commercial license through Ithaca College.

Erwin Rollauer wrote:

You have to have the latest GA version. Trial versions don’t count for
beta program
att1.dat (112 KB)


#23

No worries then. Just put your old key back in…hmmmm….hopefully it
will take your old key.

If it doesn’t let us know…I’m worried that the new Quest
licensing system might get cranky, but I’m probably just being paranoid.

Once you got your old key back in, the beta should be good to go.


#24

No worries then. Just put your old key back in…hmmmm….hopefully it
will take your old key.

If it doesn’t let us know…I’m worried that the new Quest
licensing system might get cranky, but I’m probably just being paranoid.

Once you got your old key back in, the beta should be good to go.
moz-screenshot-138.jpeg