Toad World® Forums

How do I keep the column alias on the same line when using formatter?


#1

How do I get formatter to keep the SELECT column alias on the same line ans the column name?

I want this:

SELECT
b.sgbstdn_pidm person_uid
, a.academic_period_mod
, b.sgbstdn_levl_code student_level
, b.sgbstdn_coll_code_1 college

Not this:

SELECT
b.sgbstdn_pidm
person_uid
, a.academic_period_mod
, b.sgbstdn_levl_code
student_level
, b.sgbstdn_coll_code_1
college


#2

Formatter tries to keep formatted code between left and right margins. Could it be that the right margin setting is too low?

Andre


#3

Well, the right margin is set at 100 so its not the problem in this section.

However, these are selects for views and when I stripped out the view and tried it by itself the problem went away!

So I think you’re on to it. Something is causing these to stack. I’ll go do some more testing to see if I can narrow it down.

Thanks Andre!