Toad World® Forums

Ignore blank lines within the SQL Editor for SQL

I’m using 12.9 and if I have any SQL statement that contains any blank lines then the statement below that shows as a red circle with an exclamation mark. Hitting PF9 doesn’t run the query and complains about the red circle.

An SQL query like the one shown below won’t run. Blank lines between the SELECT and the FROM puts a red circle by the blank line and the FROM statement

select sysdate

from dual

How do you get rid of this so that blank lines are ignored?

Disable “Treat blank line as statement terminator” in Options on the Execute/Compile page.

That worked. Thanks.