Toad World® Forums

No TNS option?

My computer crashed and I need to re-install Toad. I have installed the tnsnames.ora file and set the ORACLE_HOME and TNS_ADMIN shell variables. I have SQL developer installed and it is working fine. But when I go to set up the connection in Toad, it only gives me options for direct connections rather than use the TNS entry. I would like Toad to get the connection information from the TNS entry (is this called OCI?)

I know there used to be (are still??) issues with Toad x64. I have a 64 bit OS, and have installed the x64 version of SQL developer, if that makes a difference.

The connection properties disable the Oracle Client tab when it can’t find a client. Please reveiw the help topic, create Oracle connections, on installing instant client. I assume that is what you have as you mention manually editing the registry and TNS_ADMIN.

If this does not resolve after restarting TDA, then please send me the following items.

  1. Support bundle
  2. Screenshot of Oracle registry
  3. Contents of PATH variable.
  4. Screenshot of the OCI files and what path they are in.


I installed the instant client ( and set the path variable, but still cannot create the connection. I do not know what you are looking for with respect to the screenshot of the oracle registry. Are you looking for a specific key in the registry? I did send the support bundle with the other information requested. By the way, I did not manually edit the registry as you indicated in your reply. I only edited the environment variables.

Debbie, have you had a chance to look over the support bundle or do you have any other ideas for things that I could check to try and fix this?

I never recieved any support bundle.

Are you using 32-bit or 64-bit instant client? TDA needs to use 32-bit. The zip file you mention above leads me to believe you have 64-bit. Can you check?


It was assigned case id 1082629. However it can be closed now. I installed the 32 bit Instant client and everything is fine now. Thanks for the help!

Installing 32 bit Instant Client fixed it.

Glad to hear this is resolved. I will let support know to close the case.