Toad World® Forums

Output not ordered


#1

Since today morning I’m finding a problem, analytics report
is not showing the results in the specified order.
If I run a query in Editor I can see my reults ordered by the columns mentioned
in ORDER BY clause.
I get the expected results when I run the query in Toad for Oracle.
The report used to show me the orderd output till yesterday, i’ve o/p
saved in pdf file. However now when I run the preview it doesn’t show me
ordered o/p.
I tried log off and log on … no sucess.
Anyone knows what the solution is ??


#2

Debbie,
Is this problem with the ORDER By clause is because of
deleting the Application data directory ?
My control pane was not visible and when I tried 2-3 times by deleting the
application data directory now I’m able to access common cntrols but
as mentioned in below post i’m not able to see the report in ordered fashion.
(which I used to ).

Please let me know if you’ve any solution to this.

Thanks
Harshad


#3

If you have the order by clause in your query then it should be correct. To check the underlying query you can click on toolbutton “Edit underlying query”.

If this seems ok then try exporting in a different format to see if this pdf conversion issue.

Debbie


#4

Good morning Debbie,

As I said in earlier post, the report was running fine showing ordered o/p
in pdf as well as html format. I made no changes to the report, now
it doesnt show the report o/p by orderd id.
The underlying query when run in analytcs editor or regular toad shows
o/p in orderd format.

I even changed the order by clause from ASC to DESC but the effect doesnt
take place in report.( did this by right clicking on repot in project mngr
and edit properties. Also tried clicking tool bar button to “edit underlying
query” tried both ways … no effect )

Even if i build the report from
1 runing the query in editor ( result : ordered o/p)
2 click on any cell
3 send to report designer
4 build from scratch
5 Report output …not in ordered format.

I tried deleting application directory and cache file.


#5

I tried to reproduce this issue and can’t. The only other area to check is the sort fields collection of the detail band. You can add a sort order to the field you want. This won’t explain what happened but may fix the issue for now.

Debbie