Toad World® Forums

Preventing double quotes around table aliases in the query builder editor

Hello:

Is there a way to prevent toad from adding double quotes around table aliases in the query builder editor?
I am using toad 12.1.0.22.

Thanks

Adding quotes is the only way to ensure that all objects should be interpreted in a proper way.

Imagine tables with these names:

“THE END” (has space in name)

“color_me” (must be in small caps!!)

etc.

If you use them without quotes you’ll get a sql error.

So because user can define table as you like, placing quotes around is more then welcome habit when work as DBA. And you should also try to adopt to that.

Brg

Damir Vadas

Options -> Oracle -> general -> Double Quote Object Names -set to minimal. The query builder should honor this setting.

The query builder should honor this setting.

What do you mean by this-not following you …

Brg

Damir Vadas

Simple - setting this option to minimal removes the quotes. I was hoping the user would just try this without me having to verify it - hence should honor. So I just did it and it works as expected (quotes removed) - hence it did honor it.

Unfortunately, it doesn't do it. Here are the steps I did:

  1. I set Double Quote Object Names to Minimal under Options->Oracle->General

  1. I opened the query builder tab.

  2. I added a table. I double-clicked on the table header to edit the table alias. I set it to a.

  3. Here is what toad does:

Now I have to go and remove the double-quotes manually from the code Generated Query tab. Unfortunately, if I add a new table and change the table alias toad puts again double-quotes.

One more thing, it does the same thing for column aliases.

Aha - I did not do step #3. So setting removes quotes for table names but not aliases. So that would be a bug then in my opinion (but don’t assume that as the final answer). So I’d recommend opening a support case and logging it. Thanks for the steps to clarify - and sorry I missed it the first go around.

PS - I also forwarded to QA and dev in case anyone just happens to have any free time to investigate and fix it. But that’s more luck of the draw vs. official support - so again best to work it via support.

Thank you.

This does look to be a bug in Query Builder. I’ll see if I can get it fixed for the next beta.

If you’re not already on the beta program, I’d recommend trying the beta. That way, you not only get the latest development efforts; but you also get to be
part of the process that helps shape TOAD into what you need it to be. The latest beta can be downloaded here:

http://www.toadworld.com/products/toad-for-oracle/toad_for_oracle_beta_program/default.aspx

-John

From: costab [mailto:bounce-costab@toadworld.com]

Sent: Tuesday, January 14, 2014 1:59 PM

To: toadoracle@toadworld.com

Subject: RE: [Toad for Oracle - Discussion Forum] Preventing double quotes around table aliases in the query builder editor

RE: Preventing double quotes around table aliases in the query builder editor

Reply by costab

Thank you.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or
Unsubscribe from Toad for Oracle - General
notifications altogether.

Toad for Oracle - Discussion Forum

Flag
this post as spam/abuse.

@Bert,
clear now.-thx.

@All,
excuse me, but i still do not understand why removing quotes should be a problem?

THX in front on any kind of answer.

Brg,
Damir Vadas

I created this request because I didn’t like the fact that the query builder surrounds table aliases with double quotes even though it doesn’t have to.

So, let’s say I have a simple select statement:

select * from table

If I add an alias to this table in query builder, it produces:

select * from table “t”.

If I choose fields the query will be:

select “t”.field1, “t”.field2, …, “t”.fieldN from table “t”.

The double quotes in this context are not necessary. The query is not incorrect but they add visual noise to the query. The query builder tool should have produced this query instead:

select t.field1, t.field2, …, t.fieldN from table t.

This should be fixed for the next beta.

@costab

THX for answer.

Brg

Damir Vadas