Toad World® Forums

RTF File Corrupt -- MS Word Can't Open -- TOAD


#1

I’m using TOAD Data Modeler 5.0.5.31. I converted a CS2 model to TOAD. I was able to generate HTML and PDF reports, but when I try to generate an RTF report Microsoft Word tells me that my file is corrupt. I’ve tried closing TOAD without saving my changes, re-converting the CS2 and trying to generate the report, but it was also corrupt.

I really need the Word version – any suggestions on how I can get this to work? Thanks.


#2

Letting MS Word try to open it resulted in the corrupt message. Trying to “open and repair” didn’t work either. I then set the “open” box to RTF (rather than “any”) and then tried “open and repair” and the file did open. I then saved it as a Word .docx.


#3

Well, sorry to say I have the same problem again today with a different RTF report. This time the trick I used yesterday (set the “open” box to RTF (rather than “any”) and then tried “open and repair”) didn’t work. I’ve done a bit more research and this may be a Microsoft Word issue, and not a TOAD issue. Apparently MS Office 2010 has problems opening both .doc and .rtf documents. This may be something to consider, and in future releases of TOAD perhaps .docx should be used rather than .rtf (or perhaps an Open Office file format).


#4

Hi, can you zip the RTF report and send it to modeling@quest.com, please? I would like to check if the file is or is not really corrupted.

And can you try to open it on different machine, please?

Thanks,


#5

I will try to open it on another PC tonight. I also downloaded Open Office and tried to open it with that program, but it didn’t work. The file did open in Word Pad, I saved it as “RTF” in Wordpad and then MS Word could open it – but much of the formatting was compromised.


#6

Hi, I sent you repaired doc and additional info to your email box.

Regards,


#7

Hi, the problem was found and I sent you more information via email. New change request: CR#110662.

Regards,


#8

Hi Friends, Are you unable to access your RTF file? Are you getting error messages? Then, why not trying Mac data recovery software. LINK REMOVED.