Toad World® Forums

'Save As' Window Not Working

The problem here is that the buttons for ‘Save’ and ‘Cancel’ in the ‘Save As’ pop-up window do not function. The window otherwise works as intended (but is still useless!). I also discovered that moving the window will blank out these buttons, or blur them (was going to include screenshot, but apparently that is more complicated than I care to bother).

Toad Data Point 4.2.1.303 (32 bit) running on Windows 10 Enterprise (64 bit) version 1703 build 15063.674.

One of my employees noted this issue for the past couple of weeks on versions 4.0 and 4.1, and I could not replicate on 4.2. The problem first occurred for me on Friday (11/3), and is consistent in its behavior (e.g., does not work) now. Work around is to copy query file and change the name prior to opening, but I have not found a method to save changes made to an open file using ‘Save As’ to avoid overwriting the original query.

Anyone else experiencing a similar issue?

hi -Wes-,

That is very odd. Any chance this is a permission problem? Are you saving on a network shared folder? Does it happen on all folders (i.e. your Desktop)? Could you try to open normal Notepad and open Save as on folder location you’ve tried from Toad saveAs dialog?

Just a note - Toad uses the same SaveAs dialog window as most of the Win7+ windows applications and only contains an additional control at the bottom which extends it but the interaction logic of that dialog is really re-use from the .Net core (just thinking a loud).

Martin

Thanks, Martin, I appreciate your reply!

It doesn’t seem to be a permission problem. While I do keep my queries on a shared resource, access to that source is not limited when this occurs (e.g., it works fine in other applications), and I also cannot restore the button functionality by choosing any other save location (such as desktop, My Documents, etc.).

Interestingly, today when I first tried to test the above functionality, the Save As dialog box worked just fine… twice! However, upon going to another open query and doing the same thing, it was back to broken (and was also then broken for the first query attempted).

This is actually a known issue and recorded as QAT-11608. Unfortunately we have spent many hours on this and the fix eludes us. We have customized the dialog for use with our Library. Do you use our library module and add tags, catagories etc? Perhaps we need to provide an option to use the standard windows dialog if a user wants to.

No, I do not use any of the personalizing (e.g., topics, tags, etc.).

I installed TDP 4.3 today, and the problem persists. Thank you for letting me know that it is a known issue!

I looked this issue today. I found that if you turn off the Auto add files to the library you will use the old Save dialog and won't have this issue.

Debbie:

Thanks for the update! I tried this change and it seems to have made an immediate impact. Also, I discovered in the intervening months that just skipping the mouse operation and hitting “enter” after entering the new file information will bypass the inoperative buttons.

That is very useful info. I will add to the coding task for review.