SQL Editor Find and Replace not replacing trailing space in the find string.

IS: ‘Use Regular Expression” and “Replace All” with a find string “, “ {note the trailing space after the comma}

And a replace string of “\n, xyz.”

Editor text is:

SELECT Columnname1, Columnname2, Columnname3, Columnname4, Columnname5, Columnname6, Columnname7

FROM TableName

Results like:

, xyz. Columnname2 <- notice the space between the ‘xyz.’ and the ‘Columnname2’.

Should Be:

, xyz.Columnname2 <- notice no space between the ‘.’ and ‘C’.

Hope this is helpfull


Thank you for your support. We create TSS-377 for this issue and follow it.

Thanks again!


The regular expression engine uses ignore white space option when searching in the editor.

This is pretty obvious if you just try to find ", " that it only matches the , character. If you instead search “,\s” it works as expected.

Unfortunately this is not something that we can easily change because it is in a 3rd party library.