Toad World® Forums

TDA 2.7 Set Variable Question

I am trying to build an automation process where my report will get updated based on a variable.

I am setting the variable using a sql script:

Select
Case When DD.(MSP_DT) = TRUNC(SYSDATE-1) THEN 1
ELSE 0
END AS DateCheck
From Schema.Table DD

I am having an issue where it is saying no connection…and I am connected to the database… Any help?

Can you post a sample script where you are having this issue? There is connection info in the variable activity. There must be some issue there.

Debbie

Timestamp Message
2/21/2012 3:45:02 PM Activity ‘Set_Variable_1’ validation failed: Connection for SQL is not set.

I dont see the connection for the set variable…could you possibly point me in the right direction.

Thanks Debby, Appreciate the quick repsonse.

I would provide a full script but I had a computer issue.

When I go into the Variables section It offers me the option to set the variable or SQL. I enter the SQL but cannot seem to get rid of the exclamation mark. I have even tried to put the connection before the set variable but it will not allow me to drag the set variable into the connections activity.
TOAD.jpeg

Please see attached picture.

Igor.

Double click on activity to activity editor. Then press drop down to get variable collections. In this editor select the SQL drop down. This will display a small editor where you can select your connection, enter SQL and test.

Debbie

Thanks you guys…really appreicate it

Ok have another issue. I am getting an error everytime I run something. Could be a system issue but not sure.

I am getting this error. I have both 3.0 and 2.7 installed on the system and 3.0 runs fine but 2.7 gets this error everytime.

Are you using a Run Activity when you get this error? Or does the script ever get running?
Can you send me your automation script and a log file for it to my email? I will take a look and see if I can suggest something.

dpeabody@quest.com

Debbie

The script will run but this happens everytime I try to run a script. Automation and just a regular SQL statement outside of automation I still get this.

Are any other copies of Toad running at the time of the error? Also, go to Toad | Options. What is your “Allow multiple copies of Toad to run” option? Try changing it.

Debbie

Yes I usually have some automations running in 3.0 and or TOAD for Oracle 11. Checked the multiple copies of toad to allow that but still got the same error.

That error stack is very unusual. Can you check your logging type. Is it set to “event”. If so please change to “File”.

Debbie
Logging.png