Toad World® Forums

Toad 11 - Tabs in Editor gives "List index out of bounds (-1)" error

Toad for Oracle version: Freeware 11.0.0.116

With more than one file open in the Editor window, when I try to change the current active tab, the error “List index out of bounds (-1)” appears. The only way to focus an already open tab is to close all the other ones until it appears on screen.

EurekaLog 6.0.25

Application:

1.1 Start Date : Mon, 31 Oct 2011 12:41:44 +0100
1.2 Name/Description: Toad.exe - (Toad for Oracle)
1.3 Version Number : 11.0.0.116
1.4 Parameters :
1.5 Compilation Date: Thu, 25 Aug 2011 21:19:52 +0100
1.6 Up Time : 19 minutes, 49 seconds

Exception:

2.1 Date : Mon, 31 Oct 2011 13:01:34 +0100
2.2 Address : 004354A5
2.3 Module Name : Toad.exe - (Toad for Oracle)
2.4 Module Version: 11.0.0.116
2.5 Type : EListError
2.6 Message : List index out of bounds (-1).
2.7 ID : 51FF
2.8 Count : 1
2.9 Status : New
2.10 Note :

toad_error.png

I can’t reproduce this error. Can you provide steps?
~WRD000.jpeg

I can’t reproduce this error. Can you provide steps?
image001.jpeg

Also if you can send Call Stack section from the EurekaLog report it may help to
narrow down where the error is coming from
~WRD000.jpeg

Hi,
steps to reproduce error:

  1. Log into database
  2. Open two files in the editor window
  3. Click the tab for the file currently not in focus

The mouse pointer changes after I click OK on the error message (see image):

Call Stack Information:

|Address |Module |Unit |Class |Procedure/Method |Line |

Running Thread: ID=5688; Priority=-2; Class=; [Main]
01EFE282
01EFE278
015B74F5
015B7418
015B763A
015B75F8
015B7412
77692210
771AF006
771871F4
771871C9
77187DF5
77187DEB
0238D8B2
76AB3675

Message was edited by: fredriklarsen_296
toad_mouse_pointer.png

I’m getting the same error also.

Did you just copy the toad exe into your 10.6 folder or did you do a fresh install and migrate your user files?

I just copied the toad exe into the 11 folder I believe.

On Mon, Oct 31, 2011 at 2:44 PM, Gregory Liss wrote:

Did you just copy the toad exe into your 10.6 folder or did you do a fresh
install and migrate your user files?

I copied the upgrade file into the 10.6 folder, but when i got a lot of errros I did a full install.

I did not migrate any user files.

Message was edited by: fredriklarsen_296

I tried to uninstall all my Toad installations, restart the computer and then do a fresh install. Still got the same error message.

Hi everybody

I have the same problem, but also I have the same error message, when i try to edit a package…

I have copied the toad.exe new file on the old Toad folder, but anything change.

I have tried to rename toad.ini, so when I log in on Toad, it will be re-created, but anything change, I have the same errore message…

Have you any news???

Thanks in advance
Pino

Are you also using the freeware version?
image001.jpeg

I have copied the toad.exe new file on the old Toad folder, but anything
change.

This is most likely the problem. You have to run the new Toad 11 freeware
installer, you can’t just copy over the exe.
image001.jpeg

I have tried for a second time to uninstall my toad installation, delete all old folders, restart the computer, download the installer and do a complete install of 11 Freeware from scratch. This error is still present.

*Edit: I renamed the the folder “C:\Users<Username>\AppData\Roaming\Quest Software\Toad for Oracle\11.0 freeware”, it got recreated when i restarted Toad and now it works fine. Perfect!

There is a chance that when you ran the uninstaller, it did not clean up your
app data files. Try this:

  1. close Toad

  2. locate your Toad app data folder, on Windows 7 it’s:
    C:\Users[user]\AppData\Roaming\Quest Software\Toad for Oracle\

  3. Once you locate this folder, delete or rename all of the sub folders within
    this directory. They should be named after Toad versions.

  4. Open Toad

please let me know if this fixes your issue
image001.jpeg

A full support bundle would also help. Go to help > support bundle and you can
send it directly to me. bradley.boddicker@quest.com

Thanks
image001.jpeg

Hello,

I am getting exact the same error since I updated to Toad Version 11.0.0.116.

I am using a licenced Toad for Oracle Base with DB Admin Module.

The rest of Toad seems to work fine.

Is any help available?

Thank you !

Thorsten

Please zip your user files directory and send them to me offline and I’ll take a
look. Also, did you copy user files from a previous installation at the startup
wizard prompt or did you start as a fresh installation? You can locate your user
files folder in Toad’s options. See the General tab and the “Application data
directory” groupbox.

Michael

Thanks for your answer!

How can I send you anything offline ?

I mean out of context of this thread. Send it to my private, Quest address so
that none of your potentially sensitive data in the User Files folder will be
available to others on this public list.

michael staszewski quest com

Michael