Toad World® Forums

Toad for SAP Solutions crashing upon establishing a connection

Hi there,

Something bizarre has started happening since today following a password change of my database user.

As soon as I log into our production Sybase database, Toad pauses for about 2 seconds and then abruptly closes without actually displaying an error. Before requesting the password reset, it worked perfectly fine.

And If I do the same thing in version 1.1, I get this error below (note that this too worked before the password reset):

System.AccessViolationException
Invalid pointer
Stack Trace:
at Sybase.Data.AseClient1.AseConnection.Open()
at Sybase.Data.AseClient.AseConnection.Open()
at Quest.Toad.Db.Connection.OpenConnection(IDbConnection connection)
at Quest.Toad.Sybase.SybaseConnection.OpenConnection(IDbConnection connection)
at Quest.Toad.Db.Connection.AllocConnection()
at Quest.Toad.Db.Connection.Connect(Boolean notify)
at Quest.Toad.Db.Provider.BackgroundConnector.CreateBackgroundConnection()

Also, if I insert an incorrect password, it says "Login failed" - so the authentication is clearly working. Logging into our test databases works fine.

Any ideas?
I'm on Windows 10 Enterprise, Version 1803, OS build 17134.706
Sybase version: 15.7/EBF 27353 SMP SP139

The closest thing I have to a log file is the NGen.txt file which mentions this error for the following DLLs but that gets populated well before the crash.

Error: "Could not load file or assembly XXXX.dll or one of its dependencies. The module was expected to contain an assembly manifest."
DLLs referenced by XXXX: msvcp90.dll,msvcr90.dll,myodbc5S.dll,myodbc5w.dll,myodbc5S.dll,myodbc5w.dll,dbcon16.dll,dbicu16.dll,dbicudt16.dll,dblgen16.dll,dblib16.dll,dbodbc16.dll,dbrsa16.dll,libodbcHDB.dll,msvcp100.dll,msvcp110.dll,msvcr100.dll,msvcr110.dll,sybcsi_core210.dll,sybcsi_openssl210.dll,sybcsi_profiler210.dll,sybcsi_propertiesconfig210.dll,sybcsi_rolecheck210.dll,sybdrvodb64.dll,dbcon16.dll,dbicu16.dll,dbicudt16.dll,dblgen16.dll,dblib16.dll,dbodbc16.dll,dbrsa16.dll,libodbcHDB32.dll,msvcp110.dll,msvcr110.dll,sybcsi_core210.dll,sybcsi_openssl210.dll,sybcsi_profiler210.dll,sybcsi_propertiesconfig210.dll,sybcsi_rolecheck210.dll,sybdrvodb.dll,libadonetHDB.dll,libSQLDBCHDB.dll,SybaseResources.dll,git2-75db289.dll,Microsoft.WITDataStore64.dll,dblgen16.dll,dbrsa16.dll,FmtOptions.dll,libsybskrb.dll,msvcp90.dll,msvcr90.dll,QP5.dll,ToadPro.dll,ToadProfilerLib.dll

it looks like a client issue, TSAP updated ASE client and will be available in next release, let' see how it works with new client

Cindy

Thanks for that, Cindy. I'll wait until the next release.