User package is missing!

Ok, I think I found another bug …

It started yesterday, whenever I open any model, I get the “User Package Is Missing” error, and I can no longer generate DDL scripts, or verify model, or anything.


I think this problem is related to this one posted at:

Nevertheless, let me describe a situation when this message can appear.
I change paths in Settings | Options | Paths | Paths to Packages to another location.
In the new location, My Package.txg file is not stored. (It is still stored at the default location.) -> Therefore this message pops up.

Solution: I have to copy My Package.txg file to this new location too.

Here’s information from the Help file:
Path to Packages is a path to a location where user packages are stored. In this location, My Package.txg file MUST exist.
If you like to change the path to packages, you need to make a copy of the My Package.txg file from the default location to the new location.
Default location is:
C:\Documents and Settings\user name\My Documents\Toad Data Modeler\Packages{SOME GUID Number}.