Toad World® Forums

Version 7 install : C++ Library requirements

I also had the admin priv issue. After invoking the latest *.msi file on the command line, I got this :


It says : This application requires Visual C++ Redistributable package or higher.

I have : both a 2015 reditributable and a 2017 redistributable package on this machine.

any ideas?

64-bit Toad for SQL Server need to 64-bit Visual C++ Redistributable packages, please check if you have 64-bit VC++ 2015 (or above) is installed.

I have 2015 VC++ (X86) and 2017 VC++ (X64) installed 14.14.26429

Please, try to find the following registry key on your machine:
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\VisualStudio\14.0\VC\Runtimes\X64
This is the key that the MSI installer uses to check whether Visual C++ Redistributable package is installed. Some versions of Visual C++ 2017 Redistributable deleted the 'Runtimes' key, breaking the logic of version detection.

I only have the ...\Runtimes\x86 registry entries in my registry. What do I have to do to fix this?

Your tip worked. I re-installed the x64 Redistributable and running the installer as admin worked this time. Thanks

Cool, I'm glad it worked for you.