Problems with multi-byte characters

There are two problems with the following code:

  FOR i IN 1 .. 100 LOOP
    dbms_output.put_line( '💔' );

Executing with F9 raises:

[Error] Execution (5: 2): ORA-06550: line 5, column 3:
PLS-00103: Encountered the symbol "end-of-file" when expecting one of the following:

   ; <an identifier> <a double-quoted delimited-identifier>
The symbol ";" was substituted for "end-of-file" to continue.

Selecting the whole text and executing with F9 raises:

ORA-22921: length of input buffer is smaller than amount requested
ORA-06512: at "SYS.DBMS_LOB", line 1163
ORA-06512: at line 13
ORA-06512: at line 56

Thanks I can reproduce that.
The first problem, running that block with F9, doesn't seem to happen with "regular" unicode characters. For instance, I tried replacing the broken hearts with these Chinese characters: 大大大 and it worked ok.

As for the dbms_output problem, that will be fixed in version 16.1 GA.

Yeah, I only stumbled upon the first problem when I tried to reproduce the dbms_output issue.