[17.1.417] Generate Schema Script - constraints other than FK are missing

I tried to use "Generate Schema Script" to export a schema that I have already been able to export successfully in the past.

This means that the settings are still set correctly from the last time.
This time, however, the "Constraints" folder only contains FK Constraint. Check and PK constraints are missing.

All constraint types are checked:
Bildschirmfoto 2023-12-11 um 13.31.53

The "output/Scripts" options:
Bildschirmfoto 2023-12-11 um 13.33.48

Any idea what is causing this?

I'll have to "Check". haha.

Do you have tables and/or indexes also checked?

DId they get combined with tables, even though the "combine" option is not selected?

Tables and Indexes are checked as well.
The PK indexes are exported as expected.
The Tables files are containing no constraints. Just the create table and the comment on statements.

Hi Dirk,

I don't have .417 to test with anymore, but I just tried with .437.

I just ran GSS using the beta, and also 17.0, to different folders. Each exporting only constraints, tables, and indexes, and using the same "Individual object scripts" as your selection above.

When I compare the resulting "constraints" folder, both folders contain files like :


They contain Check, PK, and Unique constraints. Do you not have these files?

For me, 17.0 and the beta are producing identical Constraint folders, except for two things:

  1. Constraints on views (no longer present in 17.1 because views were excluded)
  2. Table names no longer have the spaces replaced with underscores in the file name.

Hi John,

I've installed .437 and tried again, but with the same result.
I forgot to mention my constraint options:

Bildschirmfoto 2023-12-12 um 07.19.14

So I expect one file per constraint and no <Table_Name>_NonFK.sql.

By the way, I have included Views, but these have no constraints.

HI Dirk,

I am able to reproduce the problem now and will have it fixed soon.

Thanks for reporting it and for sharing the details