Toad World® Forums

auto naming

I used the ‘non identifying relationship’ button to create a relationship between Table A and Table B.

I can see Table B now automatically

  1. identified the foreign key field in green colour

  2. added a Index ‘IX_Relationship’

I am wondering why this new Index doesn’t use auto naming convention or if there is a way I can set up a template like “IX_tablename_nn”

IDX_ttttt_nn

Hell,

what kind of naming convention do you mean?The tool from the menu Tool | Naming Convention is not designated for this purpose. The naming conventions can be used to define rules for customs names of objects, not for the default names. For this purpose is better to specify default name of the relationship on the from Default values (menu Settings | Default values).

If you want to specify the name of the foreign key, you can do it the Option | Physical model | Relation Attribute name / Relation Attribute caption.

Hope it help. Regards,

Dave

You can also change the name of FK index on the same place as the name of the foreign key (I.e. it the Option | Physical model | General | Index to Foreign key name.

Dave

Thanks Dave, I had seen Tools->Naming Convention but not Settings->Default Values, this did the trick.