Autocommit for "Explain plan current statement"


I’m using TOAD 12.8b27 and there’s something a bit “annoying”: each time I use the Explain Plan functionality, TOAD asks to commit/rollback when closing the session.

I think there should be “PLAN_TABLE Autocommit” option, to avoid using the available one that would affect other transactions (let people choose, since the existing one can be dangerous).

Besides, it will become more clear that some transactions are still pending (ignoring those related to plan_table).


Well you can’t isolate commits to just one table, but we do have an option that will make it stop prompting you.

Go to Options -> Oracle -> Transactions. On the right hand side, under “Session for Explain Plan”, choose “Separate Session”.

You may have to close and reopen your session after changing that option, I can’t remember for sure.

OK, thanks! Worked like a charm