Toad World® Forums

Automation Designer - Execute Script issues

Hi,

So in my scenario i am comparing about 80 schemas to 1 “Gold” schema, which creates a diff script and then i want to execute all of those scripts.

I’ve created an app in automation designer that i run from command line that runs the comparison, creates the diff scripts, then it gets to the execute script step and it fails after running the first script because of errors.

When i run this in toad it prompts after every script due to errors even though in the Script Error Options i don’t have the “Fail Action on Script Error” box checked.

I’ve also tried checking the box along with the “Except if error is in the ignored list” box and adding all of the errors to the list and checking those and i get the same result.

I’m using Toad for Oracle Xpert version 12.10.0.30.

Is this a known bug?

Thanks,
Scott

Is this a known bug?

At the very least there is room for major improvement here. When run manually from your action’s properties dialog you should get the prompts. When run outside of that context there should be no GUI or messages shown. That’s the ideal behavior and we’re working on cleaning up these cases now as a matter of fact. It doesn’t much help in an automated scenario if Toad is showing a message dialog requiring your attention. I’ll log this one.

In the meantime maybe you can restructure to create a single master script that calls all of the diff scripts and have your action execute the master. That way if any fail you’ll only get a single prompt to address after the master has completed.

Michael