Toad World® Forums

Toad Automation Crashes When Running Automation Apps


#1

I’m attempting to set up a basic Schema Compare through Toad’s automation designer. The ultimate goal is to call this with a Jenkins job and then copy the result files. I’m currently stuck on getting the automation jobs to run through even the UI, as each time I try to run the App, Toad crashes. The odd thing is that running the individual actions inside of the app works fine, and only if I run through Properties->Next->Run. Any other way that I try to run this app results in Toad being caught in perpetual spinning-mouse-of-death mode until I kill it through Task Manager. It is only on this particular Toad installation I have this issue it seems, as I’ve tried on 2 different PCs with the same setup and things worked out fine. I have already tried re-installing. Anyone have any insights?

SOLVED See bottom post.


#2

Which version of Toad is this?

It hasn’t happened in a while. but in past versions, I have seen problems where in some situations, a query would never reach the last row, and would cause being stuck in a loop as you describe. A newer Oracle client may fix this, or a newer version of Toad.


#3

Thanks for the reply.

Toad For Oracle is at version 13.0

Oracle Client is Oracle 12c 12.1.0.2

I previously had to move my toad installation location by cut and paste due to running into the Oracle bug with path names that contain parens, as the full installation process is a bit cumbersome the way this particular machine is set up. Is it possible to have corrupted something there?


#4

No, I don’t think moving the installation would do that. I use that trick to have a 32 bit and 64 bit installation of the same version on my machine and have not had any trouble with it.

I haven’t noticed this problem in versions as recent as yours.

Can you be more specific about “Any other way that I try to run this app…” How exactly are you running it? Does it make a difference if the comparison is very small (for example just comparing one object type in a pair of schemas)?

You can turn on Spool SQL (Main Menu -> Database -> Spool SQL -> Spool to Screen) to help see what’s going on. If it is spitting out queries, you should probably just wait. If it seems to stop working then yeah maybe we have a problem. Also you can use Session Browser of another installation of Toad to see if Toad is waiting for a query to finish.


#5

I’ve tried using two different methods to run. Through the command line (Toad.exe -a “AppName”) and through the UI by right clicking and hitting “Run” on the App.

A run that only compared Table objects completed successfully, though did hang for a few seconds.

Using Spool on the App that is failing shows a blank screen, as Toad seems to crash nearly immediately after selecting “Run” on the app.

The instance we’re running on is 2 core @ 2.3GHz with 8GB of RAM. 64 bit Windows 10 with 32-bit versions of Toad and Oracle.


#6

Hanging for a few seconds is normal. We have to run a bunch of queries and process the results. The more object types you check, and the more objects in your schema, the longer it is going to take to run. Run time should be roughly the same no matter which way you run the action.

Any error message when it crashes?

You may be able to solve it by resetting Toad (in this case You would have to recreate your actions and any other settings you’ve made in Toad). To do that: Main Menu -> Utilities -> Copy User Settings -> Reset to a clean set of user files, then hit OK. Toad will restart.

Your settings are in a folder like: C:\Users(your user name)\AppData\Roaming\Quest Software\Toad for Oracle\13.0. When you do the reset, that folder gets renamed with _bak and a new folder is created. So you can rename it back (with Toad not running if course) if you ever want to return to your old settings, or copy some files over (Connections.XML, for instance, if you want to get all your connections back)


#7

No error messages besides Windows telling me that Toad has stopped responding. Task Manager shows Toad is using about 50% of CPU power and 1.7 MB of RAM during this time. Resetting the User Settings seemed to have no effect. It’s a pretty bare-bones installation to start with anyway, just the connections to each DB we need.

Thanks again for your assistance. Anything else I should take a look at?


#8

That’s a ton of RAM it’s using. Do you have a lot of objects in your schema?


#9

Yes, not sure on exact numbers, but we’re using toad to compare them all besides Types, Materialized View Logs, and Java Sources.


#10

50% CPU tells me that Toad is busy doing something…maybe producing a sync script, maybe sorting lots of schema objects, etc. I did make some changes in Toad 13.1 to be a little more efficient at that.

But once your memory usage gets up around 1.5G in 32 bit Toad (or any 32 bit app), you’re pretty much at the edge of what it can handle, memory wise.

I’ve seen big APPS schemas, especially when comparing packages and package bodies, be too much data for 32 bit Toad to handle. Comparing packages and package bodies (if that’s where you think all that memory is going) separately from everything else might do the trick.

OR… get 64 bit Toad and see where that lands you. You’ll need a 64 bit Oracle client to go with it. Ideally, get Toad version 13.1 64 bit if you can.

All that said…if you can do the same comparison…same schema, same object types selected…(and it finishes) from the schema compare window, then it should finish in about the same time by rt-click run. That “Toad is not responding” business might just settle itself out if Toad can finish up with the amount of RAM that it has to work with.


#11

Seems you might have seen my MB as GB. Toad is only using 1.5 MB of RAM.

It takes roughly a minute or 2 for things to complete in the schema compare window for each DB, about 6-8 minutes total. I’ll leave Toad to do its thing for 30 minutes and it will still be in this state. I can look into switching us to the 64 bit installation to see if that works better.


#12

Oh, yes, you are right. In that case, I don’t expect 64 bit to solve anything. Toad 13.1 may solve it though.


#13

Uh, wait a minute. 1.7 MB? You sure about that? When I just start Toad and don’t even make a connection, it is using around 85 Mb.


#14

Very sure, unless Task Manager is lying to me. When I’ve reopened Toad after closing, it’s at ~40MB of RAM. When I run the App it jumps to ~50MB for a few minutes, then comes down to 1.5MB


#15

Wow, weird. Is 13.1 an option for you?


#16

Ya, getting it installed now. 64-bit seems to be a bit more of an obstacle though.


#17

If you aren’t approaching 1.5 Gb of memory usage, then 64 bit doesn’t buy you anything, so no problem there.


#18

I return with bad news. Toad 13.1 did not fix the issue. I did notice something though, when starting the automation app, I see in the top bar, the first connection open, then the second, then Toad dies.


#19

Oh. something came up recently…are both of the “Synonyms, private” options checked? If so, uncheck at least one of them. Either one, doesn’t matter which (or both). There’s a bug that we make a bad query if both are checked.


#20

Both options were checked, but unchecking one, and then both of them had no effect. Same result.