Toad World® Forums

AV in Editor after trying to sort grid data

Ran this query in Editor - beta .52:

SELECT * FROM dba_segments dseg
WHERE dseg.owner = ‘ONT’
AND dseg.segment_type LIKE ‘%INDEX%’
;

Click on SEGMENT_NAME column, click Ok to popup (sort ASC). got AV

Once this happens, that Editor tab will not execute again - F9 does nothing.

I have reproduced this a couple of times.

EurekaLog 7.5.1.0

Application:

1.1 Start Date : Tue, 27 Feb 2018 14:06:11 -0600
1.2 Name/Description: Toad.exe - (Toad® for Oracle)
1.3 Version Number : 13.0.0.52
1.4 Parameters :
1.6 Up Time : 21 hour(s), 36 minute(s), 34 second(s)

Exception:

2.1 Date : Wed, 28 Feb 2018 11:42:46 -0600
2.2 Address : 0000000009017CEE
2.3 Module Name: Toad.exe - (Toad® for Oracle)
2.5 Type : EAccessViolation
2.6 Message : Access violation at address 0000000009017CEE in module ‘Toad.exe’. Read of address 0000000000000220.
2.7 ID : 48650000
2.8 Count : 1
2.11 Sent : 0

User:

3.2 Name: CHX

Active Controls:

4.1 Form Class : TFormToadEditor
4.2 Form Text : DARDBA@TOSS2_STARK (toss2:arya) - Editor (New 8 *)
4.3 Control Class: TToadCXGridSite
4.4 Control Text :

Computer:

5.2 Total Memory : 8545914880 (7.96 Gb)
5.3 Free Memory : 959361024 (914.92 Mb)
5.4 Total Disk : 500105216000 (465.76 Gb)
5.5 Free Disk : 328759975936 (306.18 Gb)
5.6 System Up Time : 3 day(s), 12 hour(s), 41 minute(s), 15 second(s)
5.7 Processor : Intel® Core™ i7-2600 CPU @ 3.40GHz
5.8 Display Mode : \.\DISPLAY1: 1920x1200x32 96 DPI @ -1920x0, \.\DISPLAY2[PRIMARY]: 1920x1200x32 96 DPI @ 0x0
5.9 Display DPI : 96
5.10 Video Card : AMD Radeon HD 6350 (driver 8.850.0.0 - RAM 536870912)
5.11 Printer : Xerox WorkCentre 5845 PS (driver 6.1.7600.16385)
5.12 Virtual Machine:

Operating System:

6.1 Type : Microsoft Windows 7 (64 bit)
6.2 Build # : 7601 (6.1.7601.23403)
6.4 Non-Unicode Language: English (0409)
6.5 Charset/ACP : 0/1252
6.6 Install Language : English (0409)
6.7 UI Language : English (0409)

Steps to reproduce:

8.1 Text:

Call Stack Information:

|Methods |Details|Stack |Address |Module |Offset |Unit |Class |Procedure/Method |Line|

|*Exception Thread: ID=9132; Parent=0; Priority=-2 |
|Class=; Name=MAIN |
|DeadLock=0; Wait Chain= |

Comment=
7FFFFFFE
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040
00000040

Similar AV (not identical) occurred when sorting grid by GRANTEE

SELECT * FROM dba_sys_privs sp
WHERE sp.privilege = ‘SELECT ANY TABLE’;

I can post the EL info, if needed.

This was in .60 and .61

Thanks, Dale. I can reproduce now. I couldn’t originally, but the threaded queries option is the ticket.

Michael

Fixed next beta.