Bug: Blank Popup Windows in Code Analysis

Performing code analysis on a PLSQL package using Beta produces the expected list of rule violations, however when you double-click one of the violations for more information, the popup window is blank.

Thanks. I've logged this. It last worked in 16.1 and seems to have broken in 16.2.

There is a workaround although not very accessible. If you go to the Code Analysis | General page in Options you can click the Edit Rules button. Locate the rule of interest and select it. The tip text shows at the bottom right.

I have updated my Toad for Oracle Beta to version and I have retested the Blank popup windows issue. What I seeing now is that I get an error message after clicking the Code Analysis button:

Toad Support Bundle.txt (101.1 KB)


I've never seen that before but I think I see how to fix it. Please try it again when the next beta comes out on Monday.



Will you test something for me please regarding that Edge error? I want to know if all of our HTML displays are affected or just certain ones.

Please go to Database -> Compare -> Schemas.

Pick 2 schemas to compare. They don't have to be very different. If you want it to be fast, right-click on the "Object Types" tab. Choose "Uncheck all". Then manually check just one or two things that you have in your schemas (I usually go for sequences or triggers)

Run the comparison and then go to this tab. I just want to know if it loads OK. Thanks.

Sure John, I will run the Schema Compare test.

Please stand by.

I have run a schema comparison using the Toad for Oracle Beta .
I get the same error message when attempting to view the Difference Summary tab:

ok, thanks Jay.

In the Toad for Oracle beta, the Code Analysis popup dialog is displaying raw HTML source, rather the help document itself.


I'm not doubting you, but I haven't been able to reproduce any of these.

What can you tell me about your Edge settings?

Also, does the Schema Compare summary show the same?

Hi Jay,

I made another change that will hopefully fix this. We were saving the data to a temp file, then loading it, then deleting the file. But the file had an extension of .tmp. I am hoping that changing it to .html will solve.


I retested the Code Analysis popup windows using Toad for Oracle beta The Code Analysis popup dialog is now displaying The help text correctly. Thank you for your help.

1 Like

Hi Jay,

Great! Thanks for the follow-up.