Toad World® Forums

Can Someone Help me with Licence issues on freeware ?


#1

I installed on TOAD for DB2 my machine (XP) and have been trying to install freeware on my colleges machine (XP) to show him how it works. It installed properly but when he tries to connect to the DB he gets a DB Error
DB2 LUW Connections are not currently licensed.

So it cannot connect to DB

What Is wrong ??


#2

Hi,

Will you tell me what package you installed and the version?

You might have installed a z/OS version that does not come with a key for LUW.

Regards,
Adam


#3

It does not even ask what . It came from the toadworld free link … and it downloads the following zip.ToadForDB2Freeware_4.6.2.573.zip When I install everything looks good… I know he connection is good. They can use the IBM Simpleware to connect and do sqls.


#4

Hi,

Please screen capture the Help->Licensing page, and post it.

Thanks,
Adam


#5

It says trial and so does mine. they are exactly the same, They should say FREEware I assume

w
Doc1.docx (77.2 KB)


#6

Hi,

I’ll need some information from the PC with the problem. Please email the info to me directly at adam.ririe@quest.com

Did you try to apply a license key? If so, send it.

Are there any other Toad installations on the PC?

Check in \Documents and Settings\All Users\Application Data\Quest Software\Toad for DB2 Freeware 4.6 for any *.key files. Also check in the app data directory for the logged-in userid. Send the *.key files and the locations you found them.

Send a screenshot, or a list of the contents of the following registry keys:
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\DB2\InstalledCopies
HKEY_LOCAL_MACHINE\SOFTWARE\IBM\DB2\InstalledCopies\ToadF46\PROFILES
HKEY_LOCAL_MACHINE\SOFTWARE\Quest Software

Send a screenshot of the Help->About screen.

Send a support bundle from Help->Support Bundle.

Thanks,
Adam


#7

I have sent you answers to request. via my work email address


#8

Removing an old installation of Quest Central 5.0 resolved this issue.

  • Adam

#9

Hi, I faced same issue.
May you share with me the solution?


#10

Hello,

sinds this morning, I can’t open my toad for db2 6.5.0.125 freeware, it stay on a screen where I must introduce a license key.
I don’t have any because it’s a freeware

The term of freeware licensing have changed??

How to continue to use toad for db2?


#11

same problem from this morning


#12

I am facing the same problem here with the version 6.5.0.125 freeware. I’ve tried to uninstall and download the installer again, but when I reinstalled, the same issue happened.

How can we solve it?


#13

I am having this same issue too with my TOAD for DB2 freeware version 6.5.0.125. Tried uninstalling, downloading the latest installer and re-installing with the same message prompting for the license key and site message. Any help to resolve this will be greatly appreciated.


#14

I have same problem. It appears TOAD for DB2 6.5.0.125 has some kind of expiration. Installation on clean machine didn’t help - the same error “please enter a license key and site message”.

Some time ago I had same error with “Toad for SQL Server” edition. Only in that time there was newer version of TOAD available. Update to the latest version solved the problem then.
I hope they publish new version for TOAD for DB2 soon…


#15

We are working on updating the link on the freeware download page to point to a non-expired installer.
I will post here when that has been updated.
Thanks for your patience.


#16

The Toad DB2 Freeware download link has been updated.
You can download that newer freeware drop at:
https://www.toadworld.com/downloads#ibm-db2

Please ensure you have downloaded and are installing that latest version:
ToadforDB2_6.5.0.138.x64.msi


#17

The updated link with the latest version Toad Freeware for DB2 6.5.0.138 worked just fine for me, Jeff. Thank you for the quick response.


#18

Yes It works again Thanks