Toad World® Forums

Cannot Resolve Connect Identifier

Hello all,

New laptop from our IT guys. They installed everything but know nothing about ORACLE/Toad/etc.

I’ve done a bunch of trouble shooting on my own - but can’t figure this one out so any help would be appreciated. I’ll run down what I have and what’s been done so far.

IT installed 9.2 and 10.2.0 ORACLE versions in that order. However initially, they installed 9.2 and then the 10.2 client. They then installed 10.2.0 admin which was actually what I needed.

They installed Toad for ORACLE 10.6.1.3 as well.

When they had me come in to test it, it would not resolve the connect identifier from the databases I use (from a personal.ora). However it did connect to these databases directly. It could see the .ora files - and would load them into the TNSNames editor. The editor said the TNSNames file was valid when I checked it, though I had my doubts. As well at this point I could not TNSping any of the databases.

From here, IT sent me away saying they had no ideas about ORACLE and Toad. At first I thought I’d just skate with the direct connections but then another problem cropped up, when I connected to a specific database that has a view I use that pulls from a DB_link it came back with a strange error -ORA-01861 ‘literal does not match format string’ ORA-02063 preceding line from PMS_LINK. I checked with a co-worker to see if he had the same issue accessing the view and he did not.

At this point, I thought it might be the TNS file that was funny - so I retrieved the TNS file from others who are using the same version of Toad and retrieved their entries for the databases I use and added them to the corporate TNSNames file - removing personal.ora from the lot.

This had some success - I can now TNSping all the entries - proving that the TNS file is good, but Toad is still unable to connect and is tossing the same error. When I TNSping I checked and it is looking at the 10.2.0 path so it’s not defaulting to the 9.2 path. I also checked the SQLNET.ora file and the TNSNames is the first entry in the names.directory_path = (TNSNAMES, ONAMES, HOSTNAME).

I echoed the %PATH% directory for my machine and it comes back as:

C:\oracle\product\10.2.0\client_1\BIN;C:\oracle\product\10.2.0\client_1;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\system32\WindowsPowerShell\v1.0;lity\Apps\Extensions;C:\Program Files\Windows Imaging;C:\Program Files\ActivIdentity\ActivClient;C:\Program Files\CREDANT\Shield v6.8;C:\Program Files\Windows Imaging;C:\Oracle\Ora92\bin;C:\Program Files\Oracle\jre\1.3.1\bin;C:\Program Files\Oracle\jre\1.1.8\bin

The TNS_ADMIN variable is empty. Do I need to set this? I gathered that the 10.2.0 ADMIN doesn’t need the TNS_ADMIN. Though because they installed the client first perhaps it’s still looking for this? If I do set this is it set to the directory that my TNS files reside in? Or just to the same as the PATH for oracle.

As well whenever I try to connect through the 9.2 home it comes back with an OCI error message that I then have to shut TOAD down and restart it from as even connecting directly I will still get the same error message.

Sorry for the long post but I thought it was best to include every scrap of information that could be helpful.

UPDATE: I tried setting the TNS_ADMIN in the registry for the 10.2 home and it does nothing. :frowning: That was my last best shot. Anyone else have some good ideas?

Message was edited by: TammyM