Toad World® Forums

Connection issue - Toad 8.6.0.38 with Oracle 10.2.0.1.0


#1

Hi all - trying to connect my Toad with Oracle 10g. On the Toad login I get “ORA-12154: TNS:could not resolve the connect identifier specified”. The login page shows all green for SQLNet editor and TNSNames editor and Home Editor says everything is valid. (See attachment)

Any ideas?

Connection problem.doc (161 KB)


#2

The green arrow simply means the file is there and editable – not that
it’s been verified or tested.

You could have any one of a dozen errors in the tnsnames file that could cause
this error ……


#3

The tnsnames file(s) that I have tried are all valid and working on my co-worker’s machines. I get the same error no matter which one I try.


#4

Like I said you could have any number of errors – and that does not mean
because it works on coworkers machine that it must work on yours. For example if
tnsnames file uses host aliases rather than IP addresses – then your
windows hosts file woul;d have to match the other peoples’ as well. My
point is you cannot simply say it works on his box and not mine. There are too
many variables. This is most likely not a toad issue – but rather an
environment issue.