Toad World® Forums

Code analysis is not using custom result set from command prompt

Hi All,

I am trying to run code analysis from the command line using parameter file to generate output in XML format but result set used is not proper. It is not toad analysis on the basis of result set mention in parameter file it by default using Top 20 rule set.

If I try same parameter file in automation designer window of toad, XML file is getting generated with proper result set.

I have upload the custom rule set in Toad and mark as a default but still no luck. I am using Window 7 as operating system and Toad V 11.6

Can anybody help me how to resolve this issue?

Thanks

Nitin Goyal

I sent this via e-mail earlier this morning but it has not yet posted, so I apologize if you get this 2X.

Hello,

Just so I have this straight…

You are using Toad 11.6 and created a CA action in the automation designer window. You created a parameter file for this action and changed the rule set in the parameter file. When you r-click and run with the parameter file from within Toad’s GUI, it runs with the parameter file. If you run via the command line (toad.exe -a “app->action | C:\paramfile.ini”) it ignores the parameter file.

If this is correct, I’m almost positive this was found around Toad 11.6 and fixed in a later version. Is there any way for you to upgrade and verify? I just tested this in our latest commercial version 12.6 and it worked fine.

Thanks,

Brad

Hi Brad,

I was using the same parameter file in window xp system it was working in window xp but I am recently moved from window xp to window 7. After upgrading the operating system it is not working.

No, it is not possible for us to upgrade the toad.

Thanks

Nitin Goyal

Hi Brad,

I was using the same parameter file in window xp system it was working in window xp but I am recently moved from window xp to window 7. After upgrading the operating system it is not working.

No, it is not possible for us to upgrade the toad.

Thanks

Nitin Goyal