Toad World® Forums

Code Editor - Templates


#1

Enhancement suggestions:

  1. Don’t add an “enter” to the end of an template
    For example we use templates for parts of SQL Syntax. So if we fill in some “count(*) over()” then there always a new line is added to the statement.

  2. Don’t trim blanks from begin or end of the template.
    We would like to use the template "select * from " with a blank at the end of the text, because then we just can go on writing text.

It would be nice, if you implement this in next version of SQLNAV.
Thank you,
Chris


#2

Hi Chris,

1.Go into Code Editor|General|Allow Caret after EOL in the Preferences window and untick that option. As a result, no new line would be inserted after the template.

2.I will raise a CR for this.

Unfortunately, we can’t guarantee that it will be implemented by the next version. this is an enhancement request so it has a lower priority than others.

Gwen


#3

ad 1. I didn’t use this option already. Sorry, but it doesn’t work like you told me.

ad 2. OK, I’ll wait for it.

Christoph
preferences SQLNAV61.jpeg


#4

You’re right Chris. I added a CR for issue #1.

Cheers
Gwen