Toad World® Forums

Trigger Editor and blanks


#1

Hi!
Someone know why when i’m editing trigger, spaces between “referencing variables” (:new / :old) and rest of statement “disappears” ?
I’m using Sql Navigator v.5.5.0, but this bug(?) is older than that version

i would write :new.column_name := 12;

but when i digit “:”, space between “name” and “:” was canceled, “:” are shifted on the left, and statement became: :new.column_name:= 12;

It’s just an “esthetic” problem i kwon, but every time i must rewrite that space…
Is an incorrect setting in preferences?

Thanks
Cry


#2

Welcome to the Community

It must be very annoying. No idea why this is happening to you.
I tried to replicate but with no success. Could you post to this Community a screenshot displaying all preferences for Code Editors?

Does it occur also in other Nav editors… have you tried it in the 6.0 beta build?

I am also wandering whether anybody else has the same problem.

Rgds,
Andrew


#3

Thanks for your answer.
I send you my settings page, but i don’t think can be helpful, however…

No, i haven’t tried sqlnav 6.0. My colleagues don’t have the same problem,

thus i thought that version is not important.

The last attempt, is to reinstall the product completely.
The other time I had carried out an upgrade.

i will let you know

bye
Cry
prefs_codeeditor.jpeg


#4

Have you checked your Formatting options? If your colleagues do not have the same problem, then maybe it’s just your formating options are set differently.