Toad World® Forums

CodeXpert Tab

When I right click on the tabs underneath the editor, I can’t select
CodeXpert to get its tab displayed. What setting am I missing? I am using
11.0.0.116.

TIA,

Dave

David Reed

Principal Engineer

Integrated Systems Engineering and Process Improvement

Design Process Software

CWHQ2 318D

Westinghouse Electric Company

Suite 252

1000 Westinghouse Drive

Cranberry Township PA 16066, USA

Phone: +1 (412) 374-6739

Fax: +1 (412) 374-4575

Email: reedda@westinghouse.com

Home Page: www.westinghousenuclear.com

Hi David,

The CodeXpert tab was removed and replaced with Code Analyst. R-click in your
editor toolbar and make sure the CA tab is visible. Run your ruleset right there
from the main toolbar and you will see a results tab open below. You may have
also noticed blue squiggly lines under some of your code, of so, these are CA
violations and you can hover over or R-click on them to get more info about the
rule violation.

Here is some more info and a demo: http://www.youtube.com/watch?v=8MZ-FiZcExE
image001.jpeg

R-click in your editor toolbar and make sure the CA tab is visible.

What I meant to say was:

R-click in your editor toolbar and make sure the CA toolbar is visible.
image001.jpeg

You can also right click in the editor -> Analyze for CA options.

Brad:

Bert needs to update his white paper “Engineering Better PL/SQL”. I don’t see a CA toolbar when I right click the editor toolbar. Right click gives me Edit, File. Execute, Current Schema, Desktop, Macro and Source Control. There is a “Send to Code Analysis” icon.

YouTube is blocked here.

Thanks,
Dave

The first icon is send to CA. The second icon will analyze code and give you the
metrics in the editor.

I’m assuming you’re using Toad 11 commercial version with a professional
license. R-click on the toolbar again and select “restore defaults”. How about
now?
image001.jpeg

Brad:

That worked. I now have the complete toolbar.

Thanks,
Dave