Compile Selected Packages

When I go to compile selected packages from the Schema Browser ( and right click to choose a single package to recompile then I get the normal pulldown with the compile option. When I pick more than one and right click I get the "Tables" pull down. Reproduced several times.

Very strange... I'm also running 16.2 version and can't reproduce.

Just curious... a few questions:

  • if you choose another mode of Object Explorer display (see snap below) do you still get a Tables context with the Right click menu?
  • Noticed that you have selected all the invalid Packages... do you still get a Tables context on right-click when choosing other packages?

Otherwise, might need to know the exact steps you're taking to reproduce this effect.

Hi Lawrence,

I was just able to reproduce it like this:

  1. Turn on SubObjects
  2. Expand a package down into Uses and right-click on a table, like this:
  3. Select a few packages and right-click....Bug: Tables menu is shown.

From this point forward, if you multi-select packages, you get the tables menu.

You can get it to behave again by doing either of the following:

  • Close and re-open the schema browser.
  • Expand down into Uses (or Used By) again, select a package and right-click.

Thanks for reporting it. I'll fix.


Ah yes. That was it. I just went to the packages and couldn’t reproduce. Then I went to the tables in that schema, looked at some data in a table and went back to the packages. I was then able to reproduce multiple times.

Smart guys!


It's been fixed for next week's beta.