Toad World® Forums

COnnecting to a remote DB2 server using TOAD


#1

I get the following error when I try to connect to a DB2 server from toad installed on my WIndows machine

SQL30061N The database alias or database name "DCS4FAF6 " was not
found at the remote node. SQLSTATE=08004

Any help to solve this would be greatly appreciated


#2

Are you trying to connect to a z/OS database? Are you connecting through a gateway? Have you checked that the DCS catalog entry target database name matches the real location name? Have you tried connecting through the CLP?


#3

Hi,

Here are the config parameters given to me for establishing the connection and I was told that the remote DB2 resides on an OS/390 box .

DB2SYSTEM=system_name

Instance=DB2

ServerType=DB2MVS

Nodetype=U

Protocol=TCPIP

Hostname=host_ip_address

Portnumber=5010

Security=0

[DB>NDE4E458:DP2H]

Dir_entry_type=DCS

Authentication=SERVER

DBName=DCS4FAF6

TargetDatabase=USIBMVRDP2H

[CLI_ODBC>DP2H]

DataSourceName=DP2H

DataSourceType=System

DBALIAS=DP2H

ODBCParameters=No

I have been given the access credentials to connect to this DB.

I tried thro windows ODBC andeven thro CLP.

I get the same error everywhere . I was not sure what the “Location Name” means . I am new to DB2 .

Here is what I get in CLP

db2 => list node directory

Node Directory

Number of entries in the directory = 1

Node 1 entry:

Node name = TCP0001

Comment =

Directory entry type = LOCAL

Protocol = TCPIP

Hostname = stfmvs1q.pok.ibm.com

Service name = 5010

db2 => list db directory

System Database Directory

Number of entries in the directory = 1

Database 1 entry:

Database alias = DCS4FAF6

Database name = DCS4FAF6

Node name = TCP0001

Database release level = f.00

Comment =

Directory entry type = Remote

Authentication = SERVER

Catalog database partition number = -1

Alternate server hostname =

Alternate server port number =

db2 => connect to DCS4FAF6 user [username] using [password]

SQL30061N The database alias or database name "DCS4FAF6 " was not

found at the remote node. SQLSTATE=08004

Thanks in advance for your help


#4

Hello,

I am geting the below error now when I tried changing few parameters

db2 => connect to USIBMVRD user userid using password

SQL30082N Security processing failed with reason “1” (“PASSWORD EXPIRED”).

Then I tried changing it with a new password

db2 => connect to USIBMVRD user userid using old_password new new_password confirm new_password

SQL30083N Attempt to change password for user id “NANDY12” failed with

security reason “1” (“CURRENT PASSWORD INVALID”). SQLSTATE=08001

How do I change / reset my old password?

Thanks in advance


#5

I would suggest that you change your password as you log into TSO ISPF.

I believe we came across other DB2 users that could not establish a new password via the db2 connect command when their DB2 resides on a mainframe (DB2 on z/OS)


#6

Hi,

Thanks. I got connected to the DB2 on Z/OS now. But now I don’t know how to get the list of schemas in that database.

when I try to query the sysibm.sysschemata table, it says undefined for this database server .

when I try to query data from few table names got from the sysibm.systables, it says " myusername.tablename " is not defined in this database .

How to I get the correct table name ( dbname.schemaname.tablename ) . I am new to this DB2 . Any help is greatly appreciated .


#7

sysschemata is an LUW DB2 catalog table, not z/OS. Also, DB2.z/OS tables are qualified by creator.

If you’re familiar with DB2 LUW this link might help get you started - www.quest.com/quest_central_for_db2/pdfs/crossing_over_db2.pdf

IBM also has lots of good overviews of the differences and introductions to the platform.