Toad World® Forums

Database > Export > Export DDL

Toad for Oracle: 15.0.97.1178 - Database > Export > Export DDL.

I tried to export a table, I notice a few things that are not working as in the previous version:

  • Unique index / primary key
  • Formatting

The only way I can see the Primary Key is when I select "List constraints after columns" in the Tables tab and Constraints group box. Toad also renames the primary key to TABLE_PK

However, in the schema browser for the same table, in the Script tab, the primary key is there which we name PK_TABLE.

Any idea?

Thanks.

This is Toad 15.0, export ddl on scott.emp.

You can see the options that I selected. The PK is present and not being renamed to TABLE_PK.

Can you provide a script to create a table that I can reproduce the problem with?
Also some screen shots of relevant options in Toad. Thanks.

The Script tab in the Schema Browser uses the same code as Export DDL, so it should provide the same result if you have the same options specified in both places.

Hi John,

That seems to be working because I had "No constraint indexes" checked. Sorry, my bad because I didn't realize I had it checked.

Thank you.

I'm glad that's all it was.