Toad World® Forums

Date/Time Suffixes on Export Wizard


#1

Hi,

I’m trying to use the export wizard to send a report to a .csv format file. The only two date/time delimiters it allows are Date: (yyyy-MM-dd) and Date and Time: (yyyy-MM-dd HH-mm-ss)

Is there a way to customize that similar to how we can do with the select to file activity, or are these the only two we can use on the Export Wizard? If they are the only two, is there a function we can use instead on the file name to make the name something like YYYYMMDD? I tried variables and that doesn’t seem to work with Export Wizard files.

Any suggestions would be appreciated.

Chad King


#2

Variables work in the export wizzard, I have used them but you can only use one in the file path/name. So if your file name is Export_Data, just add the variable to the file name, i.e. Export_Data#variableName#.csv and don’t check the box for adding the timestamp.

To set the variable you can use Date(‘yyyyMMdd’) or Date(‘YYYYMMDD’) depending on the version I think.


#3

Greg,

I tried this by first using a bind variable called today which uses Date(‘YYYYMMDD’). I unchecked the box for adding the timestamp. I called the variable Today. Therefore the filename for example was set to export as File_#Today#.csv. Unfortunately it exported exactly like that and was called File_#Today#.csv on the export and it didnt resolve the variable.

I then tried to use a actual set variable on the automation right before the export wizard that made the Today Variable, which created the variable fine, but it also sends the file as File_#Today#.csv. I have version 3.4. Is there any other ideas or something you think I’m still doing wrong? Thanks Chad


#4

Hi I was wondering if there was any further response on this issue?

Thanks again.

Chad


#5

Hi Chad,

I will look into it today. Sorry for the delay.

Igor.


#6

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/36/7823.Script_5F00_1.tas:550:0]

Chad,

Unfortunately, this functionality was completed in 3.5. 2nd paragraph of your message accurately describes the scenario. I’m attaching the simple script which demonstrates this.

Please be aware that if you’d like to really run this script, you only can do this with the TDP 3.5 beta. This is because I used Toad Sample Database to export data and using Toad Sample Database has some specific when you try to run a script created in different version of TDP.