Toad World® Forums

File export date suffix on names - how to suppress?

(Toad data point 4.2.1.303). When I try to export a file the file name gets a date suffix, regardless of whether I I check “Overwrite existing file” or not. Is this a bug? I want to export without things being added to my chosen file names. To me that’s what an overwrite option should facilitate. I have a process where the I export should be named exactly the same every time. What else am I forgetting?

Turn off the option box to add the date suffix.

I’ll update here if I find, but having looked at Options under Tools not seeing the way to select/de-select the use of the suffix... where is it?

EDIT: one place it’s supposed to be is on the output options page of the wizard (per online wizard docs) but seems like it’s commingled with the “overwrite” selector and no way to select to do the suffix or not. Seems like a bug aka a feature I don’t fully appreciate yet.

So, bump, because i'm twisting in the wind here. Nobody knows the problem of which I speak? I see no working way that will suppress the date / time suffix in output file names. Very cumbersome.

Update. I'm pasting an image from the file-naming part of the export wizard. It is commingling the suffix with the "overwrite" option and it's a little flaky. I'm now getting it to work, but it's not clear how these two selectors inter-operate, are rather they're not behaving intuitively. It seems to me that even if I de-select the overwrite option, the choice made under date/time suffix will still get inherited. The UI should do a better job separating the two choices. image

I think you want to set it like so:

  1. Overwrite - when unchecked you will see a selection here:
  2. Should be blank, like you have otherwise you would have
  3. Should be empty (if Overwrite is checked it would add the suffix)
    But thanks for your feedback on the UI, we might revisit it.

Thx for belaboring the detail Dan. I have it working now. I happen to be doing plain-old text files but the Excel specifics may help some. (There is no section 3 that you called out for text files.)