Toad World® Forums

Date, Time, Timestamp format

I’m using TDA to query a DB2 database that has datatypes of DATE, TIME and TIMESTAMP. My problem is that the grid is using one format for all three datatypes. I’m new to TDA after using QMF for the last 10 years. Is there any way to customize the format for each datatype?

This is something we enhanced in TDA 2.7. So first download and install the latest version. Check the date formats and then if you want different ones go to Options | Grid and choose the custom tab in the Data Type Formatting box. DB2 has all three types listed and you can set your format strings there.

Cheers,

Debbie

I’m having issues with this one. I’m connecting to a Sybase database via ODBC. On the Data Type Formatting options, on the first tab DateTime set to …(G). This setting works, but date is in the M/dd/yyyy format instead of the yyyy/mm/dd format. I then checked Custom and inserted yyyy-MM-dd hh:mm:ss tt, but now every date/time column is the same.

I’ve tried the solution above, added
Odbc:DATE, DateTime, d
Odbc:TIME, DateTime, T
Odbc:TIMESTAMP, DateTime, yyyy-MM-dd hh:mm:ss tt

Still no luck. I’ve tried checking and unchecking the Custom box in the first tab, still no luck.

Can anyone help?

This works good for me in 2.5, but 2.7 and above I can not get it to display like how I like it.

Date = yyyy-MM-dd
TimeStamp = yyyy-MM-dd hh:mm:ss tt

The post you are referring to was specifically for DB2. We don't support this for ODBC, But you should be able to add a custom format on the first Data tab. See below.