Toad World® Forums

Disable "Quoted" fully qualified object names when dragging into editor?

When using SQL Server connection, when I drag a table/view to the Editor, it inserts the fully qualified name like this: MY_DB.MY_SCHEMA.MY_TABLE.

But when using a Snowflake connection (native connection in TDP 5.6) it inserts the fully qualified name with double-quotes like this: "MY_DB"."MY_SCHEMA"."MY_TABLE". Aside from it being unsightly, it also applies the highlighting style of a Quoted Identifier instead of text. Is there a way to disable the quotes?

I've done a few experiments with turning off/on the "Quote Identifiers" checkbox under Database->General in TDP's Options base (below) and it does allow the generation of SQL without quotes, but only for column names, and not for table names.

However, I am guessing that quotes are needed because of the native ODBC driver that TDP uses straight from SnowFlake. I can't get Snowflake SELECTs to execute successfully in TDP Editors unless everything is quoted.

Hm. I am able to query snowflake via toad using both the odbc connector as well as the native snowflake connector without quoting the db, schema, and table names. Hopefully they can change the quoted identifier setting to be connection or language specific.