Toad World® Forums

Disable the auto validate

Hello

My Toad triggers a auto validation of my code, i think after i enter a new line. Not compilie, just check for any errors like typos. If there are it shows me the errors.

This takes a long time, (only 1 sec, but that is to long when typing lots of code) and is realy annoying.

I have searched alot, and cannot find anything about this. Anyone know how to turn this off?

I get this when writing oracle portal pl/sql packages.
The option “Check syntax as you write” is disabled.

Could be the fact that check syntax as you type is checked on.

Go to View|Toad Options|Editor|Code Assist and tick off this option. See attached

On Mon, Nov 25, 2013 at 11:31 AM, nhv bounce-nhv@toadworld.com wrote:

Disable the auto validate

Thread created by nhv
Hello

My Toad triggers a auto validation of my code, i think after i enter a new line. Not compilie, just check for any errors like typos. If there are it shows me the errors.

This takes a long time, (only 1 sec, but that is to long when typing lots of code) and is realy annoying.

I have searched alot, and cannot find anything about this. Anyone know how to turn this off?

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad for Oracle - General notifications altogether.
Toad for Oracle - Discussion Forum

Flag this post as spam/abuse.

Another item to check (if you’re seeing the blue “squiggles”) is View | Toad Options | Code Analysis | General | Check Rules as you type

0003.capture.jpeg

Thank for your answer. That would be my guess to, but that option is off. I wrote that it was disabled, i meant off :slight_smile:

Just to test i checked it, saved and closed toad, open toad check it of and close toad. Still same as earlier

Two things. First under main menu -> help -> toad advisor launches a screen that will check your toad settings and tell you of any that are slowing things down.
Plus if it shows something, double clicking on any suggestion will take you directly into the options screen with the option in question in focus.

My guess is that you need to look under code analysis and uncheck having toad check your code for bad practices as you type. Think of the option you examined
like a spell checker and this option to be more like a grammar checker. You need to turn them both off
J

Thank you both for answers. Sounds like the "code analysis" might be whats buging me. But i dont have that menyu. Have tried to search bur there is nowhere to be found. I thought they introduced it into toad 11.5, and i run toad 11.6 (11.6.1.6 to be correct).

As you see under, i probily have that option but hidden. So i guess i have to look to i find it.

Great idea bert, didnt know of that option. Checked my toad advisor toad1.png

and there it is, "check code analysis". So i probily have it, but somewhere hidden. Tried to double click it as you sugested, but it takes me to the wrong place.

Did you change your license at some point from Professional to Standard? CA is only available in Professional and higher and it should not be turned on in the Standard version. You can manually do it by changing the setting in your Toad.ini

CXSQUIGGLES=0