Toad World® Forums

Editing datetime2 or time data types fails with computed column error


#1

EDIT: See my reply below for a correction to this post: The actual behavior is that Toad prevents editing of all fields if any field is a computed column (so far if the computed columns are based on the fields being edited).

Hello,
I’m using Toad for Sql Server freeware 5.x (the latest version, download Dec. 11). I can’t get it to allow any edits on fields with time(0) or datetime2(0) data types [EDIT: if the table has a calculated column].

[EDIT: ignore rest of this post] I get back an error message saying that the column must be the result of a union all or a computed column, but it’s just a normal base table, and without computed columns. Any suggestions? Thank you. Message was edited by: TechVsLife

Message was edited by: TechVsLife


#2

Hello
We could not reproduce it on our side
Could you please send as options screenshot: Tools->Options-> Environment->Grid->Data Type Formatting: DateTime and Custom tabs(see attach)
And it would be great if you send us ddl script with data of particular table

Anastasia
au_5.5_61.jpeg


#3

GO

GO

CREATE TABLE [dbo].[FooTbl](

[ProdCode] nvarchar NOT NULL,

[LDtme] time NOT NULL,

[RDtme] time NOT NULL,

[LTme] AS (dateadd(hour,(-6),[LDtme])) PERSISTED,

[RTme] AS (dateadd(hour,(-6),[RDtme])) PERSISTED,

CONSTRAINT [PK_FooTbl] PRIMARY KEY CLUSTERED

(

[ProdCode] ASC,

[LDtme] ASC

)
WITH (PAD_INDEX = OFF, STATISTICS_NORECOMPUTE = OFF, IGNORE_DUP_KEY = OFF, ALLOW_ROW_LOCKS = ON, ALLOW_PAGE_LOCKS = ON) ON [PRIMARY]

) ON [PRIMARY]

GO

Anastasia,

Thank you. My settings are the same as in your screenshot. However, I made a mistake: there was in fact a calculated column in the table. But still, I think this is errorneous behavior, since the column that was being edited was not the calculated column (the edit should proceed normally).

Here’s the table definition. Any attempt to edit ANY field produces an error, even if the fields being edited are NOT computed columns. (below only fields Ltme and Rtme are computed columns.)

SET ANSI_NULLS ON; SET QUOTED_IDENTIFIER ONSET ANSI_PADDING ON
Message was edited by: TechVsLife Message was edited by: TechVsLife Message was edited by: TechVsLife

Message was edited by: TechVsLife


#4

Hello,

Thank you for sending us table script. Now I could reproduce this bug and see the same error message. I’ve created CR80701. We’l fix this as soon as it possible

Anastasia

Message was edited by: anastasia.ukolova_000


#5

Thank you.