Toad World® Forums

Error at the startup while connecting to Oracle


#1

Hi,

I am getting the attached error message while trying to Connect Toad For Data Analysts 2.1.0.227 to Oracle DWH it works fine when I connect to SQL Server Database

Steps Taken To Resolve:

Reinstalled Oracle Client and Toad but this did not fix the issue.

Verified the TNS entries and all the information is correct.

Environment Information:

WIndows XP

Toad For Data Analysts 2.1.0.227

Oracle 9I client

Thanks
Saam

Error.doc (46.5 KB)


#2

I’ve never seen that error. Can you send a screenshot of the connection window that shows me how you have the connection defined?

Debbie


#3

It happens when I hit connect I have verified all the details

Database Name:

UserName:

Password:

all the details are right and verified this on my colleagues machine I am able to connect fine from his machine the issue is specific to my machine

Thanks
Sachin


#4

The error has to do with how we are serializing the values you have entered. I need to see the values so I can replicate the issue here. Can you send your connections.xml to me in private email? To do this go to connection window and use the “Export selected connection” and save to a file. Send this to dpeabody@quest.com. With that I can see if I can reproduce the issue.


#5

Here are the details Debbie. The issue I see here is I am not able to logon with the connection to Oracle on the machine the error message I have attached in my previous message pops up when I hit connect not letting me to in the only action I can do is choose a different Databse and login. I have attached connections.xml for sql server which I am able to login and Connections.xml for oracle on my colleagues machine where I see no issues. I have removed the host details in the.xml files. That is the only change I made to these files

Thanks
Sachin
Oracle.xml (888 Bytes)


#6

Here are the details Debbie. The issue I see here is I am not able to logon with the connection to Oracle on the machine the error message I have attached in my previous message pops up when I hit connect not letting me to in the only action I can do is choose a different Databse and login. I have attached connections.xml for sql server which I am able to login and Connections.xml for oracle on my colleagues machine where I see no issues. I have removed the host details in the.xml files. That is the only change I made to these files

Thanks
Sachin
SQLServer.xml (604 Bytes)


#7

Let’s try this. Using the following path change your user name and possibly the version of TDA to match your version and environment.

C:\Documents and Settings\dpeabody\Application Data\Quest Software\Toad for Data Analysts 2.6\ModuleSettings

Once in this directory, delete the ProjectManager.xml file and rename the ProjectManager.tpf file.

Then shut down TDA and restart and try the connection again.

P.S. Actually, before you do this can you send me copies of those two files so I can see if there is some kind of corruption in them?

Debbie


#8

Looks like my Windows User Profile Was corrupted. After recreating my logon the issue got resolved. Thanks for your help Debbie

SAAM


#9

Glad you have this resolved.