Toad World® Forums

Issue with TOAD Data Point 3.2, InvalidCastException

Hi all,

Need some help please. Trying to establish connections to a couple oracle 11g databases. I can connect no issues using tnsnames.ora file and sql developer tool. In TOAD Data Point 3.2 I can create connection but then on attempting to connect, receive this error as below:

System.InvalidCastException
Unable to cast object of type ‘Quest.Toad.Oracle.DBMS.DBMSOutputSettings’ to type ‘Quest.Toad.Oracle.OracleSettings’.
Stack Trace:
at Quest.Toad.Oracle.OracleSettings.get_Instance()
at Quest.Toad.Oracle.OracleToadConnection…ctor(OracleProvider connectionProvider, OracleConnectMediator mediator)

I cannot reproduce the error with version 3.2. Could you try the laterst versionToad Data Point 3.8?

Thanks

Aleksey

Hi Aleksey,

Unfortunately I am only allowed to make use of TOAD Data Point 3.2 and cannot install any other product on the work machine. Please advise if there are other details that might help you troubleshoot?

If it helps at all (doubtful) I have also successfully connected without issues to both Teradata and SQL Server 2008 and 2012 installs. It is only the oracle connectivity that is a hiccup here. Which is confounding as I say because the native toolsets have no issues. Only this product is having the issue.

Oracle connections can get very nasty if you have installed the Oracle client more than once. At a former company there was only one guy who could fix this and he had a very hard time. Unistalling the Oracle client does not remove everything. He had to look up on the internet how to really uninstall all of Oracle (registry entries, et al) and then install only one Oracle client and Toad worked perfectly after that. Hope this helps.

What Oracle client do you have - 32 or 64 bit? TDP 3.2 supports only 32 bit Oracle client.

32 bit. newly imaged machine. 11g client only installed once

You could try the following

  1. Run Toad

  2. Open Help|About dialog

  3. Click Application Data Directory link

  4. It opens a folder like C:\Users\your_name\AppData\Roaming\Quest Software\Toad Data Point 3.8\

  5. In this folder find Settings.xml and rename it to Settings.xml.bak

  6. Restart Toad and try to connect to Oracle.

You need to turn off DBMS polling in the editor.

Wow. 4 am eastern. Thanks for your dedication to the customers Debbie. You were the same guru who bailed me out 3 years ago when I had to use TOAD in an old role. I appreciate all your help! On this one, label me as dumber than a bag of rocks but how do I do that, turning off DBMS polling, in TOAD Data Point 3.2 please Debbie? I’ve been up and down the menus in the “Tools --> Options” panels and can’t find that. I started in “Editor” and then looked all around after not finding it there.

This option is pretty hidden. It isn't in the options page. Open up a SQL editor. On the message tab is a toggle button that turns on and off polling. See my screen shot. You can also go to the tools menu and turn on execution trace | to output. Then from the view menu request the output window. When you do this you can see the SQL being generated. You will see commands like this one when the option is on and you won't when it is off.

begin dbms_output.enable(buffer_size => :buffer_size); end;

OK, so I have toggled this option off, tested. no joy. restarted program, confirmed dbms output off, tried again, no joy. What’s next please?

Have you tried to delete the Settings.xml file?

regards

Aleksey

Yes Aleksey, sorry, had already tried that suggestion prior to Debbie’s notes when you posted it, and it also provides no joy. ;o(

Probably you already tried it but could you zip the entire Application Data Directory, delete it and reinstall Toad?

Regard

Aleksey

Debbie or Aleksey,

Everything suggested to date has been attempted and still cannot connect to oracle installations. Next steps?

Open up a support case and the support rep can have a webex with you to try and fix or find what we missed.

I just went back and removed the settings.xml file AFTER following your advice on the dbms output and “Ouila”, up and running. thanks much!!

On Fri, Mar 18, 2016 at 9:44 PM, Debbie Peabody bounce-Debbie_Peabody@toadworld.com wrote:

RE: Issue with TOAD Data Point 3.2, InvalidCastException

Reply by Debbie Peabody
Open up a support case and the support rep can have a webex with you to try and fix or find what we missed.

To reply, please reply-all to this email.

Stop receiving emails on this subject.

Or Unsubscribe from Toad Data Point - General notifications altogether.

Toad Data Point - Discussion Forum

Flag this post as spam/abuse.