Toad World® Forums

error


#1

i have problem when i tried to start new plan control session appear error which indicate that object reference not set to instance of object.i don’t know why this error is appearing for mr

note i am usibg oracle 11 g R1 and i setup quest sql optimizer for oracle version 8.


#2

Hi shaimaa,

In Quest SQL Optimizer for Oracle 8.0.0, we found there’s a layout problem related to Plan Control Session. You may try to restore the layout to see if the problem solved as a workaround, steps as follow:

  1. Launch the Quest SQL Optimizer for Oracle
  2. At the top-right corner of the application, click “Options”, an Options windows will be shown.
  3. At the left hand side of the Option Window, navigate the tree list “General | Options”
  4. Click on the “Restore…” button at right hand side. Select the “Optimize SQL” check box and click “Apply” button.
  5. Try to new a plan control session again.

Please let me know if the above steps help. If not, please send us the log file for further investigate by:

  1. Launch the Quest SQL Optimizer for Oracle
  2. At the top-right corner of the application, click “Help | Support Bundle”, a Support Bundle tab will be shown.
  3. Open “Optimize SQL” module and start a new plan control session.
  4. After the error message shown, go back to the Support Bundle tab, click “Save and Close” button to save the log file.
  5. Attach the file to this thread.

Thanks a lot.

Regards,
Polly


#3

Thanks alot polly
i followed your steps and it is solved my issue but when i tried to generate alternatives plan for SQL statement appear error as shown in the attached screenshot


#4

Hi shaimaa,

The error seems occurs when the application tries to get the SQL Handle of your SQL, but I cannot reproduce this error here.

If you have Toad for Oracle installed in your environment, you can run the application with the SQL Monitor of Toad for Oracle, and send us back the SQL logged in the SQL Monitor. We would like to know which SQL cause the problem in your environment.

Also, send us back the log file of the Quest SQL Optimizer for Oracle by the steps mentioned before.

You can try getting plan for few more SQL in the Plan Control session, and let me know if this error appears for the reported SQL only or not.

Regards,
Polly