Toad World® Forums

Errors while installing trial of Toad 12.12


#1

I’ve just downloaded the trial of Toad and am trying to install it. But it fails with “This package installation failed because of a unknown error.” If I expand the ‘More information’ section, it says:

CachePackageComplete returned event status code: [0x80070570].
ToadForOracle_Trial_12.12.0.39_x64_En.msi returned error code: [0x80070570], Package returned error message: [Https Error: mismatch the file IDs or the file services unreachable].

I cleaned out the “%ProgramData%\Package Cache” and “%TEMP%” directories and tried again but I get the same error.

The machine I’m installing on is Windows 7 Professional x64 and has 8gigs of RAM. I tried running it by right-clicking the .exe and ‘Run as administrator’ as well; same error.

The below block is from the installer log and include the only errors I found:

[1CD4:11C8][2018-03-30T11:48:23]i000: ThreadID:[1]:EventName:[RegisterComplete] Status=[0x0]
[1CD4:14A8][2018-03-30T11:48:23]i000: ThreadID:[10]:EventName:[CacheBegin]
[1CD4:14A8][2018-03-30T11:48:23]i000: ThreadID:[10]:EventName:[CachePackageBegin] PackageId=[ToadForOracle_Trial_12.12.0.39_x64_En.msi]
[1CD4:1CAC][2018-03-30T11:48:24]e000: Error 0x80070570: Failed to extract all files from container, erf: 1:4:0
[1CD4:14A8][2018-03-30T11:48:24]e000: Error 0x80070570: Failed to begin and wait for operation.
[1CD4:14A8][2018-03-30T11:48:24]e000: Error 0x80070570: Failed to extract payload: a2 from container: WixAttachedContainer
[1CD4:14A8][2018-03-30T11:48:24]e312: Failed to extract payloads from container: WixAttachedContainer to working path: C:\dload\TOAD\toad-for-oracle-2017-64-bit-trial-administrator-installer_2017-r2.exe, error: 0x80070570.
[1CD4:14A8][2018-03-30T11:48:24]i000: ThreadID:[10]:EventName:[CachePackageComplete] Result=[None]
[1CD4:14A8][2018-03-30T11:48:24]i000: ThreadID:[10]:EventName:[Error]
[1CD4:14A8][2018-03-30T11:48:24]i000: ThreadID:[10]:EventName:[CacheComplete] Status=[0x80070570]
[1CD4:11C8][2018-03-30T11:48:24]e000: Error 0x80070570: Failed while caching, aborting execution.
[1CD4:11C8][2018-03-30T11:48:24]i000: ThreadID:[1]:EventName:[UnregisterBegin]

Dave


#2

I’m wondering of the install package got corrupted somehow… have you tried downloading the installer again?


#3

Yes, I’ve downloaded it three times from two different computers and the install fails with the same error. I just found a knowledge base article about it and have raised a support case in order to get an MSI instead of EXE installer.


#4

OK, great, just checking. Be interested to hear if MSI helped you in this case.


#5

Yep, it did. I was able to install from the MSI with no problem.