Toad World® Forums

Feature Request / Bug Report


#1

So I loaded up TDA 2.7 and so far so good - except…

I’m editing a raw SQL query, and Toad helpfully pops up a window with the various columns in the table I’m selecting on - very nice, I like - but each column also has a + sign next to it - I’m assuming, so you can expand and see the various values in that column that you could select on. VERY BAD (at least in my case) - here’s why:

In an Oracle table (like I was working with) that has, literally, millions of rows, each with a unique value on that column, TDA 2.7 proceeded to consume ALL of my system resources before my machine finally hard locked and I had to force reboot. Not cool.

My question (since I can’t seem to find it)/suggestion is this: in the connection properties for the Database, provide us with an option to turn this loading off completely for the specified database, or even a program-wide option if the connection specific one won’t work.

I know enough not to click the + on purpose anymore - trust me! :smiley: - but it could still happen by accident, and I can definitely see it happening to one of my coworkers who doesn’t know any better.

Just my $0.02


#2

I tried this out on a table with 5 million distinct values. I did not run out of memory. It took a bit to generate but then gave the first 20 unique values and does not list all of the rows. What was the data type of the column you were using?

Debbie


#3

VARCHAR2 with a length of 8.

Currently the table in question has 7,935,234 records with 65 columns, not all of which are filled in for each record.

Debbie Peabody wrote:

I tried this out on a table with 5 million distinct values. I did not run out of memory. It took a bit to generate but then gave the first 20 unique values and does not list all of the rows. What was the data type of the column you were using?

Debbie


#4

Okay, I was able to reproduce on a table that had a lot of columns. I have entered CR80684 for this issue. Hopefully we can just fix the issue instead of having to add an option to work around it.

Debbie


#5

Glad it wasn’t just me :slight_smile:

Granted, the database I’m using Toad with is somewhat unique in the table structure and the vast number of records and/or columns per record - that’s why I suggested the option of being able to turn that feature off on a per-connection basis. Not all the DB’s I use Toad with are built quite like that.

Debbie Peabody wrote:

Okay, I was able to reproduce on a table that had a lot of columns. I have entered CR80684 for this issue. Hopefully we can just fix the issue instead of having to add an option to work around it.

Debbie