Toad World® Forums

Foreign Key Constraint Names Display


#1

Is there a way to toggle the display of foreign key constraint names? Some of the names get to be very long and makes the display very busy. Any help here?


#2

Hello,

I hope you mean names of relationships.
You can only edit the names but it’s not possible to wrap them.
You can also define different physical and logical name (caption) and select a physical or logical view then. So, e.g. caption can be shorter and then only caption name can be displayed in logical view.
Note: Regarding physical name and caption, physical name is just a solid name without any blanks. But in caption, you can divide words and put blanks.

I hope this information will help.
If you have any questions, please write me back. Thanks.

Regards,

Vladka


#3

Vladka - Thanks for your response. What I want to do is disable the
display of the relationship names altogether. In terms of showing a
developer the relationships between tables, I don’t really need them to
see the relationship names necessarily. It just makes the display and
the subsequent print of the model too busy and I spend a lot of time
unnecessarily moving the names so they are not cluttering up the
display. Is it possible to have the physical display and not have the
relationship names appear on the display?

Thanks,

Austin Devereux

This message is intended only for the use of the intended recipient(s)
If you are not an intended recipient, you are hereby notified that any
use, dissemination, disclosure or copying of this communication is
strictly prohibited. If you have received this communication in error
please destroy all copies of this message and its attachments and notify
the sender immediately.


#4

Hi Austin,

if you wish to hide relationship names, right click your workspace and select Workspace Format. New dialog opens. On tab general you can find check box “Display line names”. Uncheck it to hide relationship names.

If you wish to set the settings for all new workspaces, click Settings | Options and click the Physical Model node on the Options dialog. On tab Workspace you can find check box Display Line Names. Uncheck it.

Regards,

Vaclav


#5

Man, this is a huge help! Thanks a million!

AD


#6

Hi all,

i’m using TDM 4.3.4.10.

In the tab View on Display mode, check Caption.

In Relationship properties fill Name and leave Caption blank.

[:D]


#7

Hi,

The workaround with blank captions would work only in case your display mode was set to Captions. If you switch to Name or FullName, the relationship names will be displayed…

In Toad Data Modeler version 5.0, just click the Hide Captions icon on toolbar, and the relationship captions/names will disappear!

hide-captions.png

Good Luck,