Toad World® Forums

formatting of long parameter lists

All,

when a parameter list grows in size, formating is adjusted. to prevent source text from flowing beyond the right margin.
I'll use the example below to elucidate what I think could be improved:

In the first example on lines 818-821 each parm is on a line.
In the second example on lines 822-825, the parm is longer, but still (barely) within the border.
In the third example on lines 826-830, we've crossed the right margin. Toad moves the parms further to the left so that each parm still fits on a line by itself.
In the fourth example on lines 834-840 the parameter has become too long for this technique to work, so the p_message parameter is broken down and now occupies multiple rows.

The only thing that I personally would like to see improved is this: in the fourthe example, the parameters are still aligned to the left, even though there is no longer any reason to do so.
I would have preferred the parameters to be moved back to the right to align with the opening paranthesis. Like this:

Would it be possible to adjust formatter behaviour to format like this whenever possible?

Please note that examples three and four are very different from a formatting perspective.
I can live with example three as it is, even though I would have preferred to have an option to request the formatter to format it just like example four.

Still the code in example four is the bigger issue: it can be aligned with the opening parenthesis of the parmlist, yet it isn't.

Kind regards,
Abe Kornelis.

All,

Below please find a copy of the code I used in the example above, plus my Toad formatter options.

utl_krg.msg_log.log_debug_msg(p_schema => g_my_schema

, p_package => g_my_package

, p_message => ‘p_custno=’ || coalesce(p_custno, ‘’)

);

utl_krg.msg_log.log_debug_msg(p_schema => g_my_schema

, p_package => g_my_package

, p_message => ‘p_custno=’ || coalesce(p_custno, ‘’) || ‘, p_class4=’ || coalesce(p_class4, ‘’)

);

utl_krg.msg_log.log_debug_msg(

p_schema => g_my_schema

, p_package => g_my_package

, p_message => ‘p_custno=’ || coalesce(p_custno, ‘’) || ‘, p_class4=’ || coalesce(p_class4, ‘’) || ‘, p_percentage=’

);

utl_krg.msg_log.log_debug_msg(p_schema => g_my_schema

, p_package => g_my_package

, p_message => ‘p_custno=’

|| coalesce(p_custno, ‘’)

|| ‘, p_class4=’

|| coalesce(p_class4, ‘’)

|| ‘, p_percentage=’

|| coalesce(trim(to_char(p_percentage)), ‘’)

);

[View:~/cfs-file.ashx/__key/communityserver-discussions-components-files/86/4745.FmtPlus.txt:550:0]

Abe,

Interesting case.

Folding is done from top downwards. What you suggest is the opposite for that particular case. I don't say we can change the behavior but let's scan a little further. Would it help to disable the overflow form for parameter lists? (on overflow 1, 2, 3 set to None)

Thanks,
Andre

Andre,

thanks for the quick reply. I’m sorry I have no clear picture in my mind of the implications of your suggestion. Could youplease provide an example?

Abe.

===

Sorry, I meant in the formatter options, go to List Arrangements, Parameters, and select the None radio button near the “On Overflow on 1, 2, 3 then use” radio near the bottom.

This will disable the parameter list format with the parameters aligned near the LHS margin as in examples 3 and 4.

So would that work for you?

Andre

Andre,

thansk a bunch!

It’s just what I was trying to ask for.

Sorry fopr wasting your time.

Abe

===

No prob! You’re welcome, I thank you for spending time on improving formatter!

Andre