Toad World® Forums

how to prevent ` backtick from being added to text exported to Excel Instance

I’m QA so I just use Toad to get data to verify in my tests

I have a query that I export to a spreadsheet using the Export to Excel Instance. after putting in lots of formulas to perform calculations after i then verify that my calculated column = the value exported from Toad.

I added this to my toad query thinking it would add the formula automatically to verify the two columns are the same but the formula in that column has a before it so I have to edit the cell to remove that before it can be used as an actual formula.

‘=OFFSET(INDIRECT(ADDRESS(ROW(),COLUMN(),4)),0,-1,1,1)=OFFSET(INDIRECT(ADDRESS(ROW(),COLUMN(),4)),0,-2,1,1)’ Validate_Rslt

How can I prevent the export from adding that backtick?

Thanks,

Mike

Figured it out.

On the Export Data screen, I had to uncheck: Treat string fields as strings

I tried something like:

select ‘=OFFSET(INDIRECT(ADDRESS(ROW(),COLUMN(),4)),0,-1,1,1)=OFFSET(INDIRECT(ADDRESS(ROW(),COLUMN(),4)),0,-2,1,1)’ Validate_Rslt from dual;

And then, export result to Excel instance (previously open blank Excel instance).

I get “REF!” error what seems to be correct formula but with wrong parts.

Maybe this helps you.

P.S.

Google translate could not tell me what is “backtick”

:slight_smile:

The official character name appears to be REVERSED PRIME (`) (and it’s cousin(sibling?) is PRIME (’) aka tick. Windows probably uses grave and acute accents though. Backtick is a nickname and I think comes from the Unix word where everything is shortened for efficiency. \ is “whack” ! is bang. * is splat. Etc.

Hope this helps you Damir.