Import Excel spreadsheet with dates

Each week I use Toad to import an Excel spreadsheet which includes several columns with dates. Since I upgraded to v.15 and now v.16 of Toad the import fails with a message that the dates have an invalid format. I have tried modifying the format for the date import options and I get the same error. I can do the import using v.14 still without any special configuration on the same computer against the same database.

What do I need to do so I can do this in Toad v.16? I couldn't find any obvious change in the release notes that would cause this.

It may just be a matter of configuring the date format on the import table wizard, but if not....

Can you work up a small example for me?

This is the one that works (

This is the one that gives an error. (

The excel file is in xlsx format. I start with a .csv export of data and then bring it into Excel. I apply the automatic table format to the data and change some of the colors and column widths. Then I send it to another user who fills in some dates and strings in some columns then I import the spreadsheet using Toad to get the columns I need. When I follow the same steps in the 14 version of Toad it works, when I do it in the 15 or 16 version of Toad I get an error that the date format isn't right.

Hi Edgar,

We test the data import with every build that we produce. So I think there is something about your data that Toad doesn't like. Can you send me your Excel file? If the file contains sensitive data, feel free to just send a few rows with the sensitive data removed or replaced with X's, etc. You can email to to me at


Incase anyone else is following this, the error only happened when the "Use Array DML" option was unchecked.

It will be fixed in Monday's beta.